Toad World® Forums

Git seems to checkout to wrong directory

I have installed Team Coding (thanks to help from this forum!) and am attempting to integrate with Git Version Control Software.

My directory structure in my git repository looks like this (output of tree):

C:.

└───pwmdatawarehouse

└───src
    └───main
        └───sql
            ├───doc_owner
             ├───dwh_owner
             │   └───ddl
             ├───entl_owner
             │   └───procedures
             ├───etl_owner
             │   ├───dataload
             │   ├───ddl
             │   └───procedures
             ├───insi_owner
             └───mstr_owner
                ├───dataload
                 └───ddl

Inside of Toad, when I do a Git Login, the Repository is located at C:\Users…\git\pwmdatawarehouse. When prompted for a VCS Projects, I see Git at the top level, then src beneath it, and no more levels (I expect to see my entire tree above). So I choose the src level.

When I check out a procedure from the Schema Browser, where the actual source file is stored in pwmdatawarehouse\src\main\sql\etl_owner\procedures, the file that is checked out instead lands at the src level. So the files that are checked out are not seen by the VCS.

For example, checking out a file from the VCS Browser gives this message:

15:19:57 Info: src/main/sql/etl_owner/procedures/ETL_OWNER.CLEANUP_DIM_TRAN_VENDOR_TEXT.prc checked out to C:\Users…\git\pwmdatawarehouse\src\

I want it to be checked out to C:\Users…\git\pwmdatawarehouse\src\main\sql\etl_owner\procedures.

How can I correct my configuration?

I have tried using Code Collections but they don’t seem to help here.

Thanks for your help.

.

Our Team Coding guy is out today, Vince, but I believe he’ll be in tomorrow. This question is beyond me…

Hi Steven, found anything yet? Forget to mention that I’m using 12.1.0.22 with no add-ons. I can’t upgrade because this is the version we have licensed.

Hi

I posted my response yesterday here

http://www.toadworld.com/products/toad-for-oracle/f/10/t/24981

12.1 has an issue with Git and Sub Folders – hopefully the workaround helps

Stephen

From: DbVince [mailto:bounce-DbVince@toadworld.com]

Sent: Thursday, July 09, 2015 9:13 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] RE: [Toad for Oracle - Discussion Forum] Git seems to checkout to wrong directory

RE: RE: [Toad for Oracle - Discussion Forum] Git seems to checkout to wrong directory

Reply by DbVince

Hi Steven, found anything yet? Forget to mention that I’m using 12.1.0.22 with no add-ons. I can’t upgrade because this is the version we have licensed.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

I am able to re-create this issue in Toad 12.1 but not in later versions. 12.1 had an issue with Git using sub folders, which was addressed in Toad 12.5.

In 12.1 I was able to work around by using the following setup.

  1.  In the Git Login, set the Git repository to the etl_owner directory in the Git Repository
    
  2.  If not using Code Collections, in Team Coding Configuration set the VCS Project to  ..\etl_owner\procedures
    

This will work, but everything you want to check out will be checked out to the procedures directory.

If you use Code Collections – you can set up a separate folder in etl_owner for each object type you want to manage, and map a Code Collection for each type to its associated folder.

If you can upgrade to a later version that would be better. When I tried this on Toad 12.6, my setup was as follows and it worked as designed.

Stephen

From: DbVince [mailto:bounce-DbVince@toadworld.com]

Sent: Tuesday, July 07, 2015 3:48 PM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] Git seems to checkout to wrong directory

Git seems to checkout to wrong directory

Thread created by DbVince

I have installed Team Coding (thanks to help from this forum!) and am attempting to integrate with Git Version Control Software.

My directory structure in my git repository looks like this (output of tree):

C:.

└───pwmdatawarehouse

└───src

    └───main

        └───sql

            ├───doc_owner

            ├───dwh_owner

            │   └───ddl

            ├───entl_owner

            │   └───procedures

            ├───etl_owner

            │   ├───dataload

            │   ├───ddl

            │   └───procedures

            ├───insi_owner

            └───mstr_owner

                ├───dataload

                └───ddletl_owner

Inside of Toad, when I do a Git Login, the Repository is located at C:\Users…\git\pwmdatawarehouse. When prompted for a VCS Projects, I see Git at the top level, then src beneath it, and no more levels (I expect to see my entire tree above). So I choose the src level.

When I check out a procedure from the Schema Browser, where the actual source file is stored in pwmdatawarehouse\src\main\sql\etl_owner\procedures, the file that is checked out instead lands at the src level. So the files that are checked out are not seen by the VCS.

For example, checking out a file from the VCS Browser gives this message:

15:19:57 Info: src/main/sql/etl_owner/procedures/ETL_OWNER.CLEANUP_DIM_TRAN_VENDOR_TEXT.prc checked out to C:\Users…\git\pwmdatawarehouse\src\

I want it to be checked out to C:\Users…\git\pwmdatawarehouse\src\main\sql\etl_owner\procedures.

How can I correct my configuration?

I have tried using Code Collections but they don’t seem to help here.

Thanks for your help.

.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Hello

I am reviewing this.

Stephen

From: DbVince [mailto:bounce-DbVince@toadworld.com]

Sent: Tuesday, July 07, 2015 3:48 PM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] Git seems to checkout to wrong directory

Git seems to checkout to wrong directory

Thread created by DbVince

I have installed Team Coding (thanks to help from this forum!) and am attempting to integrate with Git Version Control Software.

My directory structure in my git repository looks like this (output of tree):

C:.

└───pwmdatawarehouse

└───src

    └───main

        └───sql

            ├───doc_owner

            ├───dwh_owner

            │   └───ddl

            ├───entl_owner

            │   └───procedures

            ├───etl_owner

            │   ├───dataload

            │   ├───ddl

            │   └───procedures

            ├───insi_owner

            └───mstr_owner

                ├───dataload

                └───ddl

Inside of Toad, when I do a Git Login, the Repository is located at C:\Users…\git\pwmdatawarehouse. When prompted for a VCS Projects, I see Git at the top level, then src beneath it, and no more levels (I expect to see my entire tree above). So I choose the src level.

When I check out a procedure from the Schema Browser, where the actual source file is stored in pwmdatawarehouse\src\main\sql\etl_owner\procedures, the file that is checked out instead lands at the src level. So the files that are checked out are not seen by the VCS.

For example, checking out a file from the VCS Browser gives this message:

15:19:57 Info: src/main/sql/etl_owner/procedures/ETL_OWNER.CLEANUP_DIM_TRAN_VENDOR_TEXT.prc checked out to C:\Users…\git\pwmdatawarehouse\src\

I want it to be checked out to C:\Users…\git\pwmdatawarehouse\src\main\sql\etl_owner\procedures.

How can I correct my configuration?

I have tried using Code Collections but they don’t seem to help here.

Thanks for your help.

.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.