Toad World® Forums

TeamCoding & GIT - working directory is not valid

Hello,

I am having issues with the Toad 13.0.0.80 and TeamCoding. To be precise, I am unable to add git address of the repository (image below). Whatever I try, I get the message "Working directory is not valid"... In what format the address should be? I have a repo on the company server. So should I enter the address of a project on that repo or should I enter local folder address connected with the company repo... Thanks

Capture

Hi Niko,

Git is a distributed version control system, so you'll first need to clone your remote repository locally first before you can start using it. You can click on the "New" button on that dialog and select "Clone an existing repository" to do that. Enter your Repository URL and an existing local Working Folder and then press OK:

tc_git

Once you do that, your local repository should appear in the Git Login page and you can simply enter your username and email address and then press OK.

tc_git2

-John

Hi jbowman,

Thank you for your reply but unfortunately it doesnt work... still the same error message.
Any idea?
Capture Capture1 Capture2

Hi Niko,

Can you check that local folder to make sure there are files in it, as well as a ".git" hidden folder? Perhaps the clone process wasn't fully successful.

-John

Hi John,

yes the .git folder is there, but only that folder because it is a new repo. I just started working on it today, I wanted to push some procedures to the git..

Hi Niko,

Can you turn on VCP debug logging and VCS commands in the output window (Team Coding -> Configuration -> User Settings -> Logging) and try logging into it again? Then, look in your Output window for any errors. If there are none, could you then close Toad and send me a copy of your VCPDebug.log file in a private message, which should be located in:

C:\users<username>\AppData\Roaming\Quest Software\Toad for Oracle\13.0\User Files

I'll send you a private message after posting this. You should be able to simply respond to that message if needed. You can find the private message in the "Messages" page of your user profile on Toad World.

-John

Hello John,

Thank you for all your help. Unfortunately, no errors... I ll send you the log via private msg.

I would like to thank John for his time. We were in contact via private msgs so he managed to solve my problem. I will post it in here in case someone else have similar issue. Of course, it doesn't necessary mean that this will solve your problem, but give it a try. As you can see, first problem is

John answer:
"Your Git client should have also installed a "git.exe" program in the "C:\Program Files\Git\bin" folder, however it may not have placed this in the PATH when it was installed. This is what Toad's Team Coding would typically use. You can check for that by clicking your Windows Start button and typing "command" to open a command prompt. Then, simply type "git" and hit enter. If you get Git's usage help, it's in the path, and this is not the problem. If you don't, it's not in the path. Add the location for "git.exe" to your global path and try again (may require a reboot)".

Basic on your OS, google how to set environment path. Considering I have windows 10 installed, I did the following:

  1. Hit windows button and search for "environment"
  2. Select option "Edit the system environment variables"
  3. On "advanced" tab, click on the "Environment variables" button
  4. New tab will open, under "System variables" (lower grid), find the "Path" variable and click "Edit"
  5. Click "New" and add C:\Program Files\Git\bin\
  6. Click "New" again and add C:\Program Files\Git\cmd\
  7. Click "Ok"

Thats should be it. As John mentioned, setting this up may require rebooting your pc.