Toad World® Forums

How Do I Make the Workspace I am working on Open when a Model Opens Automatically, And Stop TDM from Opening the All items Workspace on Model Open


#1

Hi.

I Use a Number of Workspaces in My Model

So At Any one Time I am working On a Workspace defined for the Task At hand.

Additionally I do not use the All Items Workspace At All, And Given that I have close to 1,000 Entities I Find Opening The All Items Workspace to be time Consuming and I immediately close it.

However, Everytime I open the Model within TDM, It always Only Opens the “All Items” Workspace, So I need to wait for the Designer to open and then I need to Open the Workspace I was working on Manually and Close the All Items.

I have to Assume that there is some way I can Control to Have TDM open a Workspace I want on Open of the Model.

However I may be Wrong.

Please let me know.


#2

Hi,

when you open model it is always opened first workspace of Model.

I think you can make first workspace empty or with less entities than all entities and it should be more quickly.

Unfortunately it is not possible change first workspace (it is still first created).

So my idea is

  1. Select all objects on All Items Workspace, ricght click on aome selected entity and from context menu choose “Add Into new Workspace”.

  2. If you want you can set “Auto Complete” property(right click on Workspace - Workspace Format). It is set by default for first workspace.

  3. Delete from first workspace all shortcut all delete all workspace and unset “Auto Complete”.

BTW: If Auto Complete option is set for workspace, than for each new entity will be created shortcut on this workspace.

Daril


#3

Daril,

Auto Complete option is not working.

It would be great if we have below options in TDM

  1. We can set the model properties to open the “Default Diagram” --> example: If our workspace name is A --> We can set the “Default Diagram” on the model properties as “A”

  2. That way next day if we want to continue with workspace A , if we open the TDM by default it will open the workspace A. Which makes easy to continue with our work if we have multiple workspace within the model.

Above steps are my suggestion to have this in TDM.

Thanks !!

Rajesh


#4

Hello Rajes,

thank you for your suggestion.

Please can you specify what you mean when you wrote “Auto Complete option is not working”? I tested it last version 6.4, and it is works. Auto Complete doesn’t change automatically opened workspace, it’s change behavior of workspace, that can be useful when you want to change content of other workspace and clear first workspace, that is automatically open at this time.

Thank you

Daril


#5

Hello Daril,

See my comments in green.

  1. Select all objects on All Items Workspace, ricght click on aome selected entity and from context menu choose “Add Into new Workspace”.

I followed this step by selecting all the objects on “All Items” WS and picked one entity à By doing right click I picked “Add into new workspace”.

  1. If you want you can set "Auto Complete" property (right click on Workspace - Workspace Format). It is set by default for first workspace.
    
  2. Delete from first workspace all shortcut all delete all workspace and unset "Auto Complete".
    

After completing above step 1 --> I did right click on workspace --> workspace format --> I see Auto complete is “unchecked” by default --> I closed my model by naming the new workspace as “TEST WORKSPACE” --> Later on when I open the model by default it opened “All Items” workspace NOT the " TEST WORKSPACE"

Typically …question here is how to open the latest workspace to continue the modeling work on next day, from your suggestion I am unable to follow above steps 2 and 3.

Let me know if I am missing something and please help me to understand how to use TDM to open the latest workspace to continue the data model work next day.

Thanks !!

Rajesh


#6

Hello Rajesh,
Probably I did not write it clearly. At this time you can not specify Workspace which will be opened when open model. Toad Data Modeler will always open first workspace, when you choose File - Open - Model. First Workspace that are called “All Items” has by default set “Auto Complete”.

You have probably in this workspace a lot of objects and it is reason why open this model take time. You are able insert this objects to another new workspace and origin workspace make empty or with only a few objects. If you do it, TDM will still open “All Items” Workspace when you open model, but it will be relative empty and it will not take a lot of time.

Another trick is not close model. When you close TDM and run again you will have same layout as before shutting down.

Daril