Toad World® Forums

How do I turn off Formatter Header in Toad for Oracle 12.12


#1

In Toad for Oracle 12.12, I can’t find the option to turn off the Formatter Header, i.e. the ‘automatically generated comment when Formatting’. Can someone help please?

Thanks - Brenda


#2

Main Toad Options -> Formatter. Expand the yellow “>>” on the right. Click Header, then Disable.


#3

I don’t have any formatter options. I just moved to a new laptop at work, and the Formatter options menu is missing. The left side of the Formatter menu is completely blank. I was able to sign in to my old computer where I had “Oracle Formatter Options” on the left side, and I’m not aware of any options I chose to remove it in my new install. My previous version of Toad was 12.9.0.71 32-bit. My current version is 12.12.0.29 32-bit. The FmtPlus.opt file is in the UserFiles directory. Here are the contents of that file:

[Qp5FormatterOptions]
OutputTabs=2
IndentSize=2

Version=296

Thanks - Brenda


#4

Yes you do. :slight_smile: I’ll be more specific:

  1. Start Toad
  2. On Toad’s main menu, click View, then Toad Options.
  3. About 1/2 way down on the left hand side of the Toad options window, is “Formatter”. Click that.
  4. On the right hand side is a double-arrow icon that is yellow. Click to expand it.
  5. Under that, click “Header”.
  6. On the right, click “Disable”.

#5

John - thanks! This is exactly what I did yesterday, and the left side was completely blank. No yellow double-arrow icon. However, after restarting Toad today, it is there. Something I did yesterday triggered it. Thank you for taking the time to respond. Brenda


#6

You’re welcome. I’ve never seen the icon not there, but I’ve never looked there first thing after installing Toad either. Glad it worked.