Toad World® Forums

How to remove auto format - Toad for Oracle 10.6.1.3

I do not want TOAD to “help” me format my code. I want it just the way I type it in. I have looked at all options and cannot find a way to disable this. Can someone PLEASE help with this? Thanks!

When you are in the Editor, right-click on choose Formatter - Formatting Options. This allows you to tell Toad how you want the formatter to work.

Mark

Thank you, but I could not get it to do what I want. I don’t want the FROM statements to be split on 2 lines. I like to have the table names first, then the relationships and the join last on the line. Really I would be happy if I could just turn off the auto formatting. I have searched all optiions and can’t see that.

Toad only formats your code (in the editor) when you tell it to. There is one
option to format files as they are opened – but that is off by default.

Where are you seeing Toad format your code as you type it?

Okay, I guess I was not describing my problem correctly. I want it to NOT format my files as I view/open them…which persist into the editor. No matter how I type it in, once closed and opened again, it is automatically formatted with the “join” lines split into two lines. I do not remember changing this default setting. Can you tell me how to turn it off again? In addition, in the editor, (maybe another thread) I can’t get the Tab to work correctly unless I am using a monospaced font. Editor>Behavior>TAB I have tried all 3 settings and they appear to work the same, not true tabs. Can you help with this issue also? Thank you.

There is an option in the TOAD options under Editor | Open/Save “Format
Files when opened”. Make sure that is not checked. . .

Thank you for your suggestion. but that didn’t fix it. It was not checked, but just in case…I checked it, saved, unchecked it, and saved and it still forces the format.

Are you getting this error when opening files, or is it when opening items from
the schema browser?

If it is files, have you confirmed that the file doesn’t have the
formatting you are seeing in it already by opening it in another application,
such as Notepad? (Sorry if that sounds like an obvious thing – just trying
to cover the bases because I have never had TOAD format my files for me without
my asking it to – so something is going on. J )

I don’t mind your covering all bases, because I have been known to miss the obvious. If I go into the editor and paste from notepad a view/procedure/etc. or load from a file, Toad looks like I want it…WHILE in editor. However, if I update/run the script and go into the Schema Browser to view the script or reload from schema browser into editor, that is when it has reformated. Are you using version 10.6.1.3?

That explains it. J

If you go to the schema browser and pull up any type of object and click on the
“Script” tab on the right-hand side, there is an option set for
“exports”. I think the same options apply to all scripts. This is
the first button on the tab. Click on that and the third option from the bottom
is “Format PL/SQL objects”. Try unchecking that and see if it helps.

This option may be somewhere else, but I couldn’t find it with the
standard TOAD options.

Phyllis

Fantastic! This was truly driving me crazy. I really appreciate your taking the time to answer. As it was, I clicked on the Script Tab and near the top I clicked the “View/edit script options.” There are 2 tabs there, “Common” and “Views.” The “Format PL/SQL objects” on the Common tab was already unchecked, BUT on the Views tab there was a check box for “Format.” I uncheck that and it fixed it. Thank you, Phyllis!

Glad it was what you needed. I knew it had to be some option. J

Thank you Thank you Thank you! This was also driving me crazy.

Great help guys, it was driving me nuts. Thanks a ton.