Toad World® Forums

Disable Auto Format in Toad 12.7.1.11

Hi,

I am not able to disable the auto formatting in Toad while discribing any object (F4) or while opening a object in Schema browser. Looks like there is option in other versions of TOAD. But looks like that option is modified or not in this version. Can you please help.

Thanks,

Selva

If you right-click somewhere in the package/procedure/function, near the bottom of the popup menu, you’ll find a menu item that says “Format code”. Uncheck it.

Thanks a ton John, you Saved me. :-).

  • I have done the steps you mentioned and now when I describe an object, toad doesn’t autoformat.

  • Now when I drag and drop a sql file from project manager pane, its doing autoformat. I explored the options still I am not hitting the right setup. Please help.

Thanks,

Selva.

Options -> Editor -> Open/Save -> (RHS) -> Format Files when opened.

Uncheck it.

Thank you. it worked…

I am able to disable the auto formatting for packages, procedures, and functions.

But it is still auto-formatting views when I open them from the schema navigator.

How can I turn auto-formatting of views (or of everthing) ?

Thanks

Alan

arosenthal@transcendinsights.com

p.s. I love the formatting tool in toad. but not auto-formatting.

Go into the SB LHS views tab -> RHS Scripts tab and click the button to view script options. Uncheck “format” in the views tab.

Thanks Brad. I actually had that box unchecked. But I tried checking it, clicking ok, going back in, unchecking it, and clicking ok again.

Now it seems to be working (ie. not auto formatting views)

thanks!