Toad World® Forums

How to run toad Data point .tas file in command line

"C:\Program Files\Quest Software\Toad Data Point 5.4\toad.exe" -batch=true "Path\Automation.tas"

I run it in the command line . No error message. the Automation.tas file is not executed

Anyone can help?

THanks

Assuming that you named your Automation script "Automation.tas, and that you know it runs successfully (e.g. you have tested it in the TDP GUI) then the next thing to look at is to make sure the script is reachable by TDP and that you specify the complete path for your automation script. e.g.

C:\Program Files\Quest Software\Toad Data Point 5.4\toad.exe -batch=true "C:......\Automation.tas"

Actually, it may be best to copy the command line straight from dialog panels that come up when you press the "Schedule" button...

Lastly, your automation script by default should generate a log file (unless you changed this in the Settings task of your work flow. Does the log file point to any issues?

Hi Gary, I copy the command from the schedule, but TOAD data point .tas file is not running.

"C:\Program Files\Quest Software\Toad Data Point 5.4\Toad.exe" -batch=true "$path\Automation.tas"

Also it does not generate a log file(I can see the log file when I run it manually )

from the Toad Data Point help files (F1 when in automation screen)

We need to Run the Command line as admin. It works