Run Automation Script using Command Line


I'm trying to run a .TAS file from command line as described in the documentation, but it doesn't seem to be working. Here is my command line

"C:\Program Files\Quest Software\Toad Data Point 5.0\toad.exe -batch=true "E:\ToadFiles\CLI_TEST.tas"

The task, is a simple insert statement. But, I'm not getting any feedback, it looks like it's running as it does not throw any errors.

Has anyone experienced this? Thank you for your time.


Welcome to the TDP forum.

The syntax doesn't look right the way you've posted it. You may be missing the matching end-(double)-quote to reference your toad.exe location. Also, you likely don't need quotes around your reference to the TAS file location.

That said, when you say "it doesn't seem to be working", what does this mean exactly? is the INSERT activity not happening? No command line acknowledgement or error messages?

Also, you may want to add (at least temporarily) an extra step in the automation flow to create some kind of output (e.g. log a comment, ECHO command, etc.) so you can confirm if the script ran, or at least how far it's gotten.

Thanks for replying so quickly. So, I've tried a several different combinations.

  • Quoting the execution portion and the .TAS portion
  • Quoting just the execution portion excluding quotes from the .TAS portion
  • Moving to the toad.exe file location, running just Toad.exe with the arguments
  • I have double and triple checked the appropriate file locations for both the executable and the target .TAS file.
  • I have spent a few hours trying various combinations. And I realize now the example I provided wouldn't have worked, sorry about that.

That being said, to further detail what I'm seeing, at the command line, when I enter what I believe is a proper command, there is nothing reported at the command line, in 1-2 seconds after pressing enter, the drive prompt appears (which to me signals that the process has started and completed without failure). From the Database side, I have created a test table, with an automation script that performs a single insert, however there doesn't appear to be an insert made in my test table, so the INSERT activity is not happening, I have not yet attempted your suggestion of adding an echo command as I'm not exactly sure how to do that at the moment. I would be hugely appreciative if you could let me know the step, or the command to enter.

One thing, I am curious though, as the documentation does have one note, which I'd like to check. Is there a way to confirm whether the database was installed prohibiting saving passwords?

Note from "Execute Automation Scripts in TDP 5.0:

  • The Automation module is disabled if Toad was installed with the Prohibit saving passwords option selected.

Thanks again for your help.
Kevin Regan

It was the password issue, it has been resolved. Thank you.

Glad the issue was resolved!