Toad World® Forums

Import works alone but not when used in automation script

Timestamp Message
6/10/2011 11:12:15 AM Import using connection: INVRPTD (DW), DW
6/10/2011 11:12:15 AM Table Importing to: ARP_MIRROR
6/10/2011 11:12:15 AM Reading from file
6/10/2011 11:12:16 AM Tried opening a closed connection
6/10/2011 11:12:16 AM
Error(s) occured, 0 out of 0 rows were imported and have been committed.
6/10/2011 11:12:16 AM Error importing data, please check file format options: Value cannot be null.
6/10/2011 11:12:16 AM Import Finished [6/10/2011 11:12:16 AM]
Timestamp Message
6/10/2011 11:12:16 AM 11:12:16 AM Thread (8) Error importing data, please check file format options: Value cannot be null.

How do i get around this?

I can’t figure this one out. I have an import that works every time I run it by itself, but when I run it in an automation script I get the following error.

Is INVRPTD (DW), DW the correct connection? Usually the import activity has a parent connection. Is that pointing to the correct connection? It is possible the parent connection is different than the one saved in the template. What is the 'Use Automation Conneciton" set to.

When you run the template in the application it uses the current connection. So it makes sense it works. But when used in automation it opens a connection. For some reason it is failing there.

Also, check that you have the option to save the password checked as part of your connection properties. This is required for automation.

Debbie

I just built a whole new import job to ensure that it was using the same connection as the automation template, and I got the same error. I even set the Use Automation Connection property to false and got the same error.

You can use the import activity without a parent connection. Did you try that? If it is on a parent connection, drag it off and delete the connection activity.

Debbie