Toad World® Forums

Improved error messages

I was trying to check-in a change to a stored procedure and the TFO status window shows this …

09:50:33 Output: Error checking in all files: Error uploading file: Scheme.StoredProcedureName.PRC

Where can I find the actual error?

Hey John,

Turn on “Enable VCS Debug Logging” in your Team Coding configuration window. You can also turn on “Show VCS Command Output window”. That should show you the why the upload failed.

-John

the error has gone away but I will leave the debug options turned on and update this thread when I have more details. Thanks for the quick reply.

Hey John,

Not a problem at all… Fair warning: leaving the debug options on will slow overall performance as Toad has to write every request and response to those log outputs. You may want to leave them off unless you run into a specific issue.

-John

Hi John,

I am having a similar issue. I am using TOAD 12.8.0.49 version. We are connection to Microsoft TFS.

I was able to log to TFS through TOAD successfully.

I am also able to compare code between database and VCS repository. Also able to checkout code successfully from VCS.

However when I try to checkin the code from TOAD, it throws Output: Error checking in all file: Error uploading file: <schema.procedure.prc>

I debugged the message and go the below error. Do you know what this means:

HTTP Post Error: A connection with the server could not be established -

and a link below:

URL:http://tfs..com:1/tfs/DefaultCollection2/VersionControl/v1.0/upload.ashx - SOAPAction:

I noticed that the link has the server port number ‘1’ mentioned under the ‘Genral’ tab under TC configure setting, even though I have decided not to use this and am using the alternative URL without the server port like below:

:http://tfs..com/tfs/DefaultCollection2

without server port under “Advanced Settings” tab. Is there anyway to nullify the serverport number under Genaral tab. I think tis is causing the issue.

Thank you,

Prashant


Hey Prashant,

Well, this is an older GA version of TOAD, rather than a beta version; however, I would suspect the port is defined incorrectly in your TFS configuration window. To fix this:

  1. Open the Team Coding Administration window.
  2. Next to the drop-down for Microsoft Team Foundation Server, there’s an ellipsis button. Click that.
  3. Change the port listed on that form from “1” to “80” (the default http port)
  4. Click OK to close the TFS configuration window
  5. Click OK to close the Team Coding Administration window.
    On a side note: I’d recommend upgrading your version of Toad to a more current version. Team Coding was completely rewritten for Toad 12.9 and has improved functionality, performance, and stability. Plus, you’ll need Toad 12.10 installed in order to be able to run the beta.

I hope this information helps!

-John