Toad World® Forums

VCS Check-in Success or Failure is not Apparent.? (Beta 13.0.0.61)


#1

Not a crisis but it has caused some confusion as we’re working to bring up version control. Maybe this has always been this way or maybe I’m set up wrong?

The Output window at the bottom of TOAD does not scroll to newest message.

Under Team Coding Configuration - Local Settings, I have checked both “Log Team Coding messages in the output window” and “Log VCS commands in the output windows”.

I created a script, saved it and then attempted to add it to the VCS (I’m using TFS as my VCS).

First, I clicked “check-in”. The check in window appeared, I added a comment and clicked OK, and it appeared to work. However, the script was not loaded to the VCS and did not appear on the TOAD VCS display. After waiting a while, I tried “Add file to VCS”. Everything preceded as before but this time when I looked on the server, I could see the script in the VCS on the server. As far as I could tell, there was no indication of success or failure outside of my manual checking.

However, I later discovered the following messages had been inserted into the Output viewscreen running at the bottom of the TOAD app but I didn’t realize they were there because the window doesn’t scroll.

error checking in.png

file successfully added.png


#2

Hey Douglas,

I would probably say this is a bug. I’ve logged and fixed it for Monday’s beta. Feel free to give it a shot and let me know if you run into anything else.

Thanks!

-John


#3

Looks good!