Toad World® Forums

Index Out of Bounds


#1

I ran the query, select * from dba_db_links on an oracle 10 database. after pressing F9 I am getting the following printscreen. A message that the program may have become unstable is trying to pop up, but this message repeats every second (ish). Teh x in the upper right corner is not useable to close the application. I turned on SQL Monitor to see if anything was being attempted, but nothing is being put in it. I have left Navigator Running for over 1/2 an hour and it is not finishing. Task Manager show Navigator as taking 25-35% CPU and 40,000 K of memory. Task Managers end Task did kill it…

Oh, once I killed Navigator, brought it back up (No PC reboot or anything), ran the exact same query and it worked fine.

Message was edited by: DaleFromLozier

indexoutofbounds.gif


#2

Hi Dale,

When this kind of cascading error appears, there’s no other way but to kill Nav. I don’t think this is caused by the query. My wild guess is the connection dropped and didn’t reconnect successfully and as a result could not detect that current session. Nonetheless there’s little we can do if the issue is not reproduciable.

Gwen


#3

Agreed…