Toad World® Forums

Navigator becomes unstable


#1

My SQL navigator becomes unstable when I try to run any query. It was running fine till few days ago. I’ve attached the error that I’m getting. I would be really grateful if anyone could help me.

error.dialogue.jpeg


#2

Hi Prasad and welcome to the community,

This is a very generic message, and doesn’t pin-point any specific issue(s).
It would help if you could give us the exact steps of what you are doing… and also a copy of a query that returns the error for you.

Is the application still unstable after you close and re-launch SQL Navigator ?

  • Jaime -

#3

Hi Prasad,

Which version of Nav are you using? I would recommend you doing this to fix the problem:

  • Delete this registry key from your system. Make sure you close the application before deleting the key. Start Nav again and hoplefully its fixed.
    HKEY_CURRENT_USER\Software\Quest Software\SQL Navigator n.n.n\Docking Windows (where n.n.n is the SQL NAV version, for example 5.5.4)

  • If it doesn’t work, try to launch the Task Manager from the View menu and dock this window and rerun the statement.

cheers
Gwen


#4

I’m running a simple select query with out a join. I’ve even tried re installing sql navigator.


#5

I’m using veresion 5.1.0. I was not able to find the registry key.


#6

Hi Prasad,

If you are running 5.1.0, try to delete the following key:
HKEY_CURRENT_USER\Software\Quest Software\SQL Navigator\Docking Windows.

I believe you might need to do step2 as specified by Gwen, ie. open Task Manager window and dock it to avoid the issue. Hope that it will work.
We have seen this issue a while ago and have made changes in 5.5.4 to avoid this stability timing issue which relates to the Task manager window when it is not visible.
You should try to upgrade to 5.5.4 which would address this issue for you.

Please let us know how you go.

Thanks and regards,
Bruce


#7

It wold be great if you could explain how to dock the window from task manager? How do I ge to the registry key from task manager? I tried running a new task HKEY_…/…/


#8

Thanks every one… deleting the registry key has solved the problem…


#9

Hi Prasad,

Thanks for letting us know. Glad to hear removing the key has resolved the problem.
I was just about to send you more note on how to delete the key :-).

Regards,
Bruce


#10

I just had this error also. The quest people gave me one option of adding the extension .old to the sql navigator folder in regedit. when you re-run navigator it will automatically create a new sql navigator folder in regedit. I did go back to the .old folder and traced the problem down to the “layout 0” folder in the “Docking Windows” folder. I just deleted the layout0 folder and when I re-ran navigator a new layout0 folder was created. Problem solved.