Toad World® Forums

Install probleme 10.6 on windows 7


#1

Hello,

I want to update my previous isntall of Toad 10.5 whith the new 10.6 version but the installation hang in the first step. I try a different location of the default quest installer setting directory but its the same. The installer run as Administrator.
Any idea ?

Taod_Capture.png


#2

I have toad 9.2 installed, and have the same problem trying to install 10, 10.1, 10.5 or 10.6 on Windows 7 Ultimate 32bit. I have tried all sorts of variations. I have tried running it from different locations, as administrator, in compatibility as Winxp, etc. I turned off my virus scanner, and other things that might interfere. I can’t uninstall 9.2 to try that because the license I have will only apply properly if you upgrade as opposed to install new. Any ideas?


#3

It’s important to note here that starting with Toad 10.0, each Toad
version is a new product. In other words, there is no true upgrade to your
installation, rather a side-by-side installation. You should take the default
install location for 10.6 and never install it into an existing Toad directory.
When you first run a newer version of Toad, you will be asked to copy settings
from a previous version of Toad to your new version. After everything copies
over and you are satisfied, you can uninstall your previous version of Toad if
you wish.

Your older Toad license should work with 10.6, assuming it is a permanent
license. Just make sure you copy it down before you uninstall the old version.
When you first run 10.6 you will be prompted for a license key, just enter your
license from your previous Toad into the dialog and it should work. If not,
contact quest support and they can help you with licensing issues.

Also, I’d like to know where you got your hands on Toad version 9.2,
seeing that a version 9.2 was never compiled. We went from 9.1 to 9.5 J

-Brad


#4

Also note that we did not start supporting Windows 7 until Toad 10.


#5

9.7.2 Mistype sorry. We have a permanent license, and nobody here has gotten it to apply to any version past 10 without having 9.7.2 on the machine first, I don’t know why that is, I only know that was the set of instructions I received. We have had it since at least version 7.6 D. I understand that it is not officially supported on windows 7 until 10.1.1.8 I believe, but the 9.7.2 works, and the other ones won’t install, so I am more or less stuck. Since you don’t get to choose the install location, I am unsure how to affect that one way or the other.

Thanks.


#6

You don’t get to choose the installation location? Why not? I assume you
are running the Toad installation via the Quest Installer. What do you see when
you first open the installer? What is the default install directory? Does it
indicate that Toad will be an upgrade or a new install? This might be part of
the problem if Quest installer is flagging this as upgrade rather than a new
installation.

There seems to be too many questions to continue this discussion on the group. I
think it would be best if you could send me a private e-mail with screenshots or
video of every step along the way. If we can figure out a problem/solution, we
can later share it with the group.

Thanks,

Brad


#7

Ok, I decided to try uninstalling the old version and the installer to see if that helped, figuring I would cross the bridge of the license when I go to it. Unfortunately, even with the old version removed, the 10.6 installer still exhibits the same behavior, depicted in the screenshot above.


#8

Sure, what is your address?


#9

bradley.boddicker@quest.com


#10

Sent. Thanks again for your help.


#11

Update:

We have determined that problem Scott was having was with Quest Installer, not
Toad. I have suggested that he contact Quest support so that they can get this
issue to the correct product team. Quest Installer is hanging between the
license agreement screen and the product selection screen in his environment for
some reason. I assume this is the point where the msi files are extracted to a
temporary location before they are run.
image001.gif (43 Bytes)


#12

Ok thanks , i submit the case to day !


#13

Here is the solution that worked for me. I extracted the MSI from another computer and I install the msi on my computer.

Before that I tried a complete uninstall and a new installation but without success.

Yours sincerely


#14

Quest support offered a similar solution. This is directly from the case:

As a workaround we can manually extract them and then use the MSI file to
install on your machine.

A. Download the packer.exe Utility:

  1. Visit www.quest.com
  2. Go to Support | SupportLink Home.
  3. If you have a SupportLink account already, log in; or register for an
    account.
  4. Click on the Downloads tab.
  5. Type Toad for Oracle in the keyword search bar and click on Search.
  6. Under the category facet, click on Utilities.
  7. Download the “Silent Installation Utility (Packer.exe)” that is
    dated: April 11, 2008.
  8. Choose which directory you would like the installation media to be downloaded
    to.

B. Extract using the packer.exe Utility:

  1. Place the packer.exe and Toad installer executable in the C:\temp folder.
  2. Open a command prompt.
  3. Enter the following command and hit enter:

packer.exe extract “C:\temp\Toad_Install_File.exe” “C:\temp”

C. Use the Toad MSI File to Install:

  1. Within the C:\temp folder will be a bunch of folders, locate the Toad
    standalone.
  2. Open the MSI file to install Toad.