Invalid Home Name

I have reviewed several articles and tried various changes.
Yet still am getting the "Invalid Home Name" when I attempt to connect to one of my databases.
The Oracle Homes dialogue says that the Home is valid: Yes
Instant Client - (

  • ORACLE_HOME:C:\Oracle\Ora12c\bin*
  • ORACLE_HOME_NAME:C:\Oracle\Ora12c\bin*
  • NLS_LANG:*
  • LOCAL:*
  • Client DLL:C:\Oracle\Ora12c\bin\oci.dll*
  • TNSNames.ora:V:\Oracle\Network\tnsnames.ora*
  • SQLNet.ora:V:\Oracle\Network\sqlnet.ora*
  • LDAP.ora:*
  • Login.sql:*
  • GLogin.sql:*
  • In system PATH:Yes*
  • Home is valid:Yes*

I am on TOAD connecting to Oracle 19c.
This works on my other machine, but this new one is having issues.
Thank you for any assistance.

ORACLE_HOME_NAME is invalid. It should be the name of the Oracle Home in the OUI inventory and not the path to bin.

Mine is: OracleClient19Home1


Do I change this in the registry?
Or is there another location?

Sorry, fairly new to TOAD.

In registry:


My Registry looks like this, yet the TOAD Home dialog still shows as above.
I feel like there is something simple missing here.
Why doesn't the Home Dialog read the registry entries and update?

I am not sure why that would be happening. Perhaps one of the Quest folks could tell us when and how that Oracle Home information is read from the registry by TOAD and updated in the configuration. Or perhaps TOAD keeps the info in one of its own config files though I have not found one.


Your original post says "Instant client -".

There are no registry entries for instant client. So whatever you find in the registry must apply to a full client that you also have installed (or used to have installed).

Instant client folders should not include BIN in the path. Older versions of Toad had problems with that. I don't remember which version we fixed that. Anyway, here's what I would try:

  1. Change your instant client path so that it does not end with BIN
  2. Change your system path to reflect the new path of your instant client.
  3. restart your PC (shouldn't be necessary but sometimes it is)
  4. Try again to connect with that client and Toad.

Hi John,

I have changed the system path to reflect the path of the instant client.
How do I go about changing the path in the Home dialog (see original post) if it doesn't read the registry?

If it is simpler, I don't mind making it use the OraClient12Home client, but it not sure how to get the install to accomplish that.

thank you

You don't need to change it anything in the login window. Toad searches your path to find instant clients.

You should be able to choose which client you want to use in the login widow by selecting it in this dropdown before you make your first connection. It will be disabled after that.

If you don't see the OraClient12Home client listed there, it's likely because it doesn't match the same bitness (32/64) as Toad.

I set this aside for a day and then looked at it again and found an article by you (@JohnDorlon) suggesting to do the following:

  1. Use the deinstaller to deinstall the 12.2 client
  2. Make sure there is no trace of any oracle client on your computer:
  • Hard drive (check where it was installed, and also look under Program Files and Program Files (x86)
  • System path
  • Registry - specifically HKLM\SOFTWARE\ORACLE. If it's still there, delete that node after deinstall. Also HKLM\SOFTWARE\Wow6432Node\ORACLE.
  • Environment Variables: Any oracle-related environment variables (except TNS_ADMIN) should be removed.
  1. Reboot
  2. Reinstall oracle client.
    If you have 64 bit Toad, you must use 64 bit Oracle client.
    If you have 32 bit Toad, you must use 32 bit Oracle client.

Once I did this, the correct Home directory and references showed up and TOAD is working now.
Thank you all for pointing me in the right direction.


1 Like