Invalid Oracle Home when using debugger

Hi, I'm using Toad for Oracle Base (64-bit) 17.0.341.1977 under Windows 11 with Oracle Instant Client 21_11
Everything works correctly except debugger: when I start debugging I get the error "Invalid Oracle Home"
Where should I set the home to solve the error?

Hi Marco,

I tried using 21_12 (21_11 was no longer available) and it worked fine. Maybe grab the latest and try again? Do you have a TNS_ADMIN environmental variable set up and using TNS connection method?

These steps may help if you have multiple Oracle homes installed (or if you used to and there are still traces of the old ones on your system)

Note: some of these steps concern non-instant clients.

Yes, I have the TNS_ADMIN variable. But I am not an administrator in this pc, this pc belongs to my company: maybe this could be the problem?

Solved! I hadn't set the home in the Path environment variable, I had only set TNS_ADMIN.
With the correct Path the debugger works. Thanks!

We found the reason why you were getting that error. It seems that you were connecting without the Oracle client initially, and there is a bug in Toad that it can't debug without an Oracle client installed. We'll have that fixed soon.