Toad World® Forums

Issue with TDM2 workspaces in 3.1.5.6


#1

I recently updated TDM3 Commercial to 3.1.5.6 from 3.0.11.11. Everything is working OK, but I have been experiencing a few problems. The most important of which is now, workspaces that I had previously imported from 2.25 are now not visible. I can click on the workspace in the tree-view, but all of the entities are just white boxes with gray horizontal lines. I can double-click on the entities and view/edit them, but it would be nice to be able to see the physical diagram without having to re-create them.


#2

Hello Michael,

workspaces that I had previously imported from 2.25 are now not visible.

All model workspaces are listed in the Application View and Model Explorer. Only first WS is opened in the Designer. - This is a correct behaviour. If you like to open another WS, you have to select it (double-click the WS).

all of the entities are just white boxes with gray horizontal lines. I can double-click on the entities and view/edit them, but it would be nice to be able to see the physical diagram without having to re-create them.

The problem you describe shouldn’t occur. We would like to ask you for more details.

  1. Did you do the following? - imported TDM2 model to TDM 3.0.11.11, resaved it to .txp and now opened the .txp model in TDM 3.1.5.6?

  2. When you imported it for the first time (to TDM 3.0.11.11), were the workspaces displayed properly?

  3. Did you make any changes in workspace format and display view (display level, autolayout, align options etc.) in the model before you saved it?

  4. Or did you open TDM2 model in TDM 3.1.5.6 now? Did you open .dm2 file or .dmx file?

  5. Is the WS format and the format settings of the model in TDM v2 and TDM v3 the same?

Thanks in advance for the information.

Note:
You can try to delete Configs directory from:
C:\Documents and Settings\user\Application Data\Quest Software\Toad Data Modeler (default location).
Close TDM, delete the directory and open TDM again.
It might help.
Note: Layout of TDM you migh have customized, will be lost.

If it does not help, please send us the model (or models - .txp and .dm2) and please write us more details. (You can send them to: modeling@quest.com). The models will be used only for the testing purposes.
Thanks in advance.

Regards,

Vladka


#3
  1. Did you do the following? - imported TDM2 model to TDM 3.0.11.11, resaved it to .txp and now opened the .txp model in TDM 3.1.5.6?

yes.

  1. When you imported it for the first time (to TDM 3.0.11.11), were the workspaces displayed properly?

yes.

  1. Did you make any changes in workspace format and display view (display level, autolayout, align options etc.) in the model before you saved it?

I had changed some of the color options and most of the entities are set to Recalculate size. I also periodically rdp into my desktop PC using different screen resolutions, so I watch TDM resize some of the windows.

  1. Or did you open TDM2 model in TDM 3.1.5.6 now? Did you open .dm2 file or .dmx file?

No. I had originally converted the model using a previous version of TDM3.

  1. Is the WS format and the format settings of the model in TDM v2 and TDM v3 the same?

Most likely not. I have likely made changes since we upgraded.

I tried deleting the Config folder, and it doesn’t seem to be much help. I’ve attached a Word document with a screenshot of what I am talking about. I can edit the entities ok and if I add new ones to the workspace, they display correctly.
TDM3_FunnyScreens.doc (110 KB)


#4

Hello Michael,

Please have a look at format of the entities that you cannot see and check out their font - font type and size. Isn’t the size too small? Please compare it with the font settings of the new entities that you can see properly.

If it is not the problem, please send us your model. (modeling@quest.com).

Thanks!

Regards,

Vladka + TDM Team


#5

Great! That did it! I checked the font settings for the entities, and there was no value in the size column.


#6

Perfect! Happy to hear the problem is solved. :slight_smile:

Have a nice day.

Vladka