Toad World® Forums

Job Manager - Automation Failure

We just upgraded from 3.2 to 3.3. Because of the change in Select to File, I had to rewrite a number of my scripts using Export Wizard which seemingly works OK. When I go to automate my scripts, however, I’m getting the same error on any machine I’m using. Upon hitting “schedule”, I get a pop up stating “THE PARAMETER IS INCORRECT”

My scripts are working smoothly when just selecting RUN but the actual automation of the script is failing. I’m on Windows 7 and the jobs run directly from either my system or a Virtual Machine depending on the job. Any ideas?

Jeremy

I have never seen this error. Is this still persisting? Does it occur on more than one pc?

Hello,

Yes, it is still occurring. It occurs on multiple PCs as well across not only Windows 7 but previous platforms as well. The one thing I have noticed is that it is occurring on machines that had 3.2 installed prior to 3.3. I also don’t think 3.2 was uninstalled prior to the installation of 3.3.

I am able to set up the automation by hand. It seems to have something to do with creating the actual scheduled job. IE, its directly related to the item in the job manager.

Regards,

Jeremy

From: Debbie Peabody [mailto:bounce-Debbie_Peabody@toadworld.com]
Sent: Monday, October 07, 2013 7:24 PM
To: ibmdb2@toadworld.com
Subject: RE: [Toad World - IBM DB2 Discussion Forum] Job Manager - Automation Failure

RE: Job Manager - Automation Failure

Reply by Debbie Peabody

I have never seen this error. Is this still persisting? Does it occur on more than one pc?

To reply, please reply-all to this email.

Stop receiving emails on this subject.
Or Unsubscribe from IBM DB2 notifications altogether.
Toad World - IBM DB2 Discussion Forum

Flag this post as spam/abuse.

The information contained in this message and any attachment(s) may be privileged and/or confidential and is intended for the addressee(s) only. It may contain legally privileged and protected information. If you are not the intended recipient, you are hereby notified that any review, disclosure, reproduction, distribution, or other use of this communication is strictly prohibited. If you received this email in error, please notify the sender by reply, and immediately delete the message without saving, copying, or disclosing it. Unauthorized disclosure may result in legal liability for those persons responsible. Thank you.

Hi Pucko8,

Did you ever find a resolution to this issue? I’ve encountered the same thing with Data Point 3.7. The automation script runs fine but when I select schedule, I get a message for the job manager that says “The parameter is incorrect”.

I’ve even tried creating a new task from the Job Manager and pulling in the script and it appears to run and finish but then doesn’t save where it should.

Any tips are greatly appreciated!

Hi, this was happening to me. I don’t think the automation feature liked what I named the .TAS file.

When it was Auto_Test 6.10.16.tas it would throw the error.

When I changed it to Auto_test.tas, the scheduling feature worked fine.

Thanks ekennedy! This worked perfectly :slight_smile: