Latest Beta, 17.1.707, freezes when save to C:\temp\EBSS\ and then press F6

Good afternoon TOAD team,

Latest Beta, 17.1.707, freezes when save to C:\temp\EBSS\ and then press F6. Never recovers, at least not in an hour: Twice in a row today.


Hi Larry,

  1. Are you saving the script output or the edit area at the top?
  2. F6 is the shortcut to toggle focus from top to bottom half of Editor. Is this what you are trying to do, or did you map F6 to something else?


Oh, I guess you have F6 mapped to Test/Reconnect.

Hm. For me that's working fine. Saving anything before that is unrelated. I think you are having connection/network problems. We didn't change anything there.

I've found that when Toad gets hung up like that due to connectivity problems, you can break it out of the "not responding" state by clicking the 'X' in the top-right corner of Toad. Then you get a "Toad for Oracle is not responding" dialog from windows, with one of the choices being "Try to restore the program". "Try to restore the program" usually works for me to get Toad back to "Responding". But of course that won't fix your network/connectivity problem. Also, you may not even be able to click the 'X' in the top-right corner of Toad since you have a dialog up. Maybe temporarily disabling your network will break it out of that.


Good afternoon John,






Same behavior on production TOAD 17.0 Patch 1. Likely I’m not waiting until save finishes.

Saving to a local folder should be nearly instantaneous.

Back to my first question then - are you saving the sql edit area at the top or the script output? It doesn't look like you have much to save in either place.

Good afternoon John,

I’m saving the script (SQL area), about 555 lines, yes, should be fast. Click save and immediately press F6 has killed TOAD on three different computers today. The script change is not saved, I’m getting tired of making the same edits. Also 3 times today.

I just did this using the beta.

  1. set up F6 for "Test/Reconnect" shortcut
  2. Put about a half million lines of "select * from dual" into the editor
  3. Save to a file
  4. As soon as possible, hit F6 for test/reconnect.
  5. It worked ok
  6. Made a few small edits in Editor so that I could save again without the save dialog
  7. Clicked "Save", then F6 again as fast as possible
  8. repeated steps 6 and 7 a few times for good measure.

For me, it did not hang. Not sure why it's a problem on your end...

Did you have multiple copies of Toad beta running at the same time?

If so, what was happening in the other copies of Toad beta?

I keep saying "beta" because if Toad 17.0 was also running, I don't care about that.

Good evening John,

Not even repeatable for me any longer, Ops made for network changes. As usual, I would not understand them, if they tried to tell me what they did.

I edited the file again on my Windows 11 Azure VDI and had no issues, must have been a bad network bandwidth issue. Most folks are signing off for the day now. I did your test, too. Aside from how long 540,688 select statement take to run, no issues. Also never hit the grid count limit in the past: 98 grids. Likely because I usually put these three lines at the top of long scripts:

set define off;

set linesize 4096;


I was wrong, still hit limit, but now I see The Task xxx of 540,688 progress on the pop-up. Each grid has only one line: Dummy X.

That old bug of save takes a very long time has reoccurred on this new VDI, likely mapped drives no longer defined. Where do I edit to speed up open and save?

I didn't run my script. Just saved it. Was your script running when you did the save and test/reconnect?

Not sure exactly, but you could close Toad, search for references for them in Toad.ini.

Good afternoon John,

Thank you!

No, the script was not running, why I start with F6 to reconnect, then F5 to run with all values returned. Not an issue anymore with fewer users as the applications are modernized.