Toad World® Forums

Toad datapoint connection error

Hello, I have one issue withTDP
Getting the below error immediately when a connection is made to the oracle database( I supply the credentials and clicking connect in TDP results in this error)
ora-2391: exceeded simultaneous sessions_per_user limit.

DBA informed that there was new profile restriction limiting some of the users to single session.surprisingly this issue is only for Toad datapoint users, other users using different tools have no Issue.On lot of debugging, noticed that whenever a connection is attempted from TDP then object explorer is seen and then followed by error.
And we can browse the data in the object explorer..so here object explorer has the session and when 2nd sessionn is attempted...we see the error due to the database profile. Is there a way to avoid "object explorer" and directly go to the editor window on connection.

To open an Editor when you connect you can check only the "Editor" check box in your options - Database - General - "Open on New Connection" as shown in the image

Also make sure you have manually closed the 'Navigation Manager' window, if it is open, prior to connecting.

Thanks Jeff for the response.

Unfortunately it did not work even after setting as suggested. FYI, I tested exactly same even before.
Note that I tried restarting TDP as well but still got same error as attached.
15947598022161991765641519084550|666x500

Also, I can still see object explorer and can view all objects(browse).
Somehow session is still picking the "object explorer" first and not the editor though we set in the options
Thanks in Advance.

Sorry that was not successful for you. I suggest that perhaps you should open up a support ticket on support.quest.com so all pertinent information can be captured and tracked

One last try before going to Support. Wondering if this option helps?

Made the change as suggested and still got the same error again. Thanks Gary for looking.

Your DBA could fix this, if they wanted to. Limiting to a single connection is ridiculous!