Toad World® Forums

Lost Personal and Named SQL

Running 11.0.0.116. A few weeks ago I lost all my Personal and Named
SQL. I didn’t have time to deal with it then, but now I have the time.

I went back to my 10.6 installation, fired it up and verified that my
saved SQL is still in that version. I went back to 11 and tried to
import from my 10.6 installation. I tried Append with the appropriate
check boxes checked and also Replace. Neither gave me back my saved
SQL.

I then renamed my existing 11 SavedSQL.dat and simply copied the one
over from the 10.6 install to the 11 install. Still no Saved or Named
SQL.

What am I missing or doing incorrectly? Any ideas?

John

In View|Options|Editor|Code Assist do you have this option checked? “Show only statements for the active session” If so, uncheck it and see if your statements are there. When checked all SQL that was executed in a session other than the active session will be hidden. If that option has no effect you can send me your savedsql.dat file from 10.6 to me offline and I’ll look into why it’s not carrying over.

Michael

That did it. I don’t know how that got checked, but checked it was. I unchecked it and all is well now. Many thanks!

The same thing happened to me on 11.6.1.6. Logged in today and no Named Queries. Were using them last week. The check box mentioned above was not selected. Any other suggestions? Thanks.

We had a problem with file corruption in the past. Looking at the code changes a fix was added in April of 2012 which would put it in for Toad 11.5 and newer versions. Did you get an error that the file could not be loaded when you started Toad? In your appdata UserFiles folder locate SavedSQL.dat. Open the file in a text Editor. Notepad++ is recommended because it will show control chars. In the past the corrupted files would be largely filled with null chars. If you don’t have a text editor that will show this you can send me the file offline if you’d like and I’ll take a peek. michael.staszewskiquest.com