Materialized Views not showing in reverse engineering wizard


I’m new to this and would like some advise and help with the following issue:

I’m using the reverse engineering wizard to bring in table/views and materialized views from our oracle schemas into TDM version 4.0. The connection is correct and I can see all the tables and views but can only see a handful of the materialized views, do you know why this could be?

Any help would be very much appreciated.



where can you see those materialized views in the RE wizard? There is nowhere to see them… Maybe some of their tables can be seen in Tables.
In the RE wizard, the option which can influence the range of reversed materialized views is in Option dialog (see the screenshot). When checked, it loads only user types that lie in the same schema/user as the selected tables.

Message was edited by: Lukas

See the screenshot from RE wizard.


has it helped or do you still experience any issues?


I have the same problem. Regardless of what I enable in the RE wizard, I never get to see MVIEWS from my database. I’m using TDM 5.0.5 and Oracle


in RE you can choose if you wish to reverse all Materialized Views only, single object selection is not available in the Wizard.

In case you wish to add just selected Materialized Views(MV) to your model, do reverse engineering without MV, then open the Connections form, select appropriate connection and click Open Object Explorer. Then you can use drag and drop technique to add MV to your existing models.(Some objects can be dropped to diagram, some to Physical Model Explorer).

Good Luck,


Thanks for the answer, unfortunately the object explorer as well doesn’t show the materialized views (and yes, we do have several in the schema I’m working with).

Everything else (tables, views, synonyms, procedures and functions) is showing up correctly, just not the materialized views.

I traced the statements that TDM is using and the statement selects only materialized views where the column ALL_MVIEWS.UNKNOWN_PREBUILT is ‘Y’.

I am not sure what the restriction should achieve, but in our case, all our mviews have a ‘N’ in that column (I checked several of our database and none of them contains any mview with unknown_prebuilt = ‘Y’)