MFA on Toad Datapoint 5.6 to Azure Snowflake

I am trying to connect to Azure Snowflake and it connects and accepts my entered password but when Azure sends me the MFA confirmation to my phone and I approve and gives me the passcode. I have no popup in Toad to enter the passcode. Does Toad 5.6 support MFA on Azure Snowflake?

Hmmm... check to see if the TDP popup isn't buried underneath another Window or app? I've seen that before.

Otherwise, I wonder if any of these apply? (from the tech docs)...



Thanks Gary!

I am having my admins set the mfa_caching to true. I think that will help prevent MFA everytime I open a tab to

start a new query.

After various attempts, the popup may not be necessary if you elect a push so that

you don’t need to a panel to enter a code.


OK, sounds like this is getting you on the right track?!

Hey Gary, setting the client_mfa_caching to true did not help. It is set now and I can view that it is but every time I open a tab to start a new query, it goes to authenticate. It really slows down Toad. Is there any other setting required to prevent MFA for each new tab opened?