Microsoft SQL Connection Errors

Hi all,

I've been having a problem with TDP throughout the last few versions (5.6, 5.7, 6.0).

When I'm running an Import function on an Automation, connections to Microsoft SQL Server AND Microsoft SQL Azure are failing, because TDP is inserting a GUID into the hostname for no reason at all.

When I save the Import Template, I'm saving it in the format:

TDP is actually storing it in the .tim (import template) as

See some screenshots of this below.

When TDP tries to connect to the hostname, it obviously fails because the GUID is not part of the genuine hostname.

I've raised this with support, and they are unable to fix the problem. They've raised a QAT, for the developers to fix, but we've been through multiple major version upgrades and no resolution has been found.

Is anyone else having this issue with Microsoft SQL or Azure SQL connections? The MS SQL function is completely broken, per my testing, so I would be surprised if other customers are not seeing this issue too.


Please see an additional screenshot below (sorry, I can only upload one per message).

While the Dev team members are investigating, I wonder if the work-around for now is to go into the XML and change the server names (e.g. to lop off the GUID)? Wondering if that gets you going until Quest can resolve?

Hi Gary,

Thanks very much for the excellent suggestion! I did try to remove any references to the incorrect GUID throughout the files. Unfortunately though I still get the same error. I can't see how TOAD references the connection in the connections.xml file. There is no TRL listed in connections.xml, so I assume it's matching on the name.

In any case, I simply stripped the GUID out of each of the three relevant files (connections.xml, the .tim import file and the .tas automation file), but I'm still getting the same error unfortunately.

I appreciate your assistance. Thanks very much for the suggestion.