Toad World® Forums

Minor annoyance: v12 used to ask to reconnect after wake from sleep

Just recently Toad stopped asking me if I wanted to reconnect after my machine was started from hibernate. I’d like that feature back but have no idea where I could toggle some preference to “wake it up” (sorry, couldn’t resist). Yes, I did search the plethora of options. I get very tired of closing the Error pane and dealing with Test connections (though that’s better than it could be!).

There is a ‘don’t ask me again’ checkbox on that dialog – maybe you accidentally checked it.

To “Uncheck” it, with Toad not running, edit your Toad.ini file (in your user files folder) and find

WakeUpReconnectPrompt=1

Change it to

WakeUpReconnectPrompt=0

or just delete that line completely.

From: bill.graefe [mailto:bounce-billgraefe@toadworld.com]
Sent: Tuesday, April 08, 2014 10:58 AM
To: toadoracle@toadworld.com
Subject: [Toad for Oracle - Discussion Forum] Minor annoyance: v12 used to ask to reconnect after wake from sleep

Minor annoyance: v12 used to ask to reconnect after wake from sleep

Thread created by bill.graefe

Just recently Toad stopped asking me if I wanted to reconnect after my machine was started from hibernate. I’d like that feature back but have no idea where I could toggle some preference to “wake it up” (sorry, couldn’t resist). Yes, I did search the plethora of options. I get very tired of closing the Error pane and dealing with Test connections (though that’s better than it could be!).

To reply, please reply-all to this email.

Stop receiving emails on this subject.
Or Unsubscribe from Toad for Oracle - General notifications altogether.
Toad for Oracle - Discussion Forum

Flag this post as spam/abuse.

The marked answer did answer my direct question but did not fix the real problem of not asking to reconnect. Shall I start a new thread or does anyone have ideas?

So you have WakeupReconnectPrompt=1 in your Toad.ini but it still doesn’t ask about reconnecting after wakeup?

Correct. It was 1 before. I set it to 0, reopened Toad, closed, set it to 1, and reopened. It didn’t work this morning.

reconnectset.png

Oops, sorry, I did give you the 1/0 backwards. It should be 0, not 1. A “1” value means “don’t prompt”. The best bet is to just remove the line completely and Toad will go back to default behavior. Also make sure you’re editing the right Toad.ini. If you’ve run multiple versions of Toad, you could have multiple User Files folders. The easiest way is to go to Toad Options|General, and click the “Open Folder” button in the “Application data directory” box. Then Close Toad and make your edit.

Sorry about the misinformation before. I just tested the beta here with the line missing and I did get the prompt.

I do have two versions and did get to the correct folder/file on my own. With the zero, it works.

I know what happened. The checkbox area is much larger than the text. The entire area is clickable and rests just below the yes button. I am sure I missed once and didn’t see the box go on. A bigger dialog with more space between would help. May I suggest you edit your answer that was marked correct? Additionally, there should be yet another button in Options to reset the don’t ask me again boxes (unless there’s only the one).

Thanks for the quick replies.

I’m glad it’s working again. I edited my answer. Good suggestions, thanks.