Toad World® Forums

Allow to cancel Reconnect dialog using ESC


#1

It has happened several times that after Hibernation the reconnect dialog is displayed behind a describe window. Since I cannot see the dialog I try to cancel it using ESC, but it does not close.

Could you allow ESC to cancel the reconnect dialog?

image


#2

It seems like the bigger issue is the “wake up” prompt coming up behind the describe dialog. I’ll get that fixed for next beta. Will also add ESC if I can, there may be some reason why we don’t.


#3

I have the same problem. This mostly works for me:

Click toad on the task bar to make it active. I sometimes click something rlse first, then Toad, to be sure.

Alt-space

M

Use the arrow keys to move the hidden dialogue out from under the describe window.

HTH

Cheers,
Norm. [TeamT]


#4

That’s a good tip, Norm, but I don’t want users to have to rely on it!

If any other prompts are getting stuck behind describe dialogs, please let me know.

Have a great weekend, everyone.


#5

Hi John,

Great! I was afraid that you could not fix the acutal issue, since Z-order problems like this have been around forever.

@Norm: Thanks! I actually tried that, but it did not work for me. I guess it is because this dialog does not have the top left icon to trigger the context menu.

What I used to work around this problem is a shortcut that has saved me several times while working with TOAD: Ctrl + Alt + Esc


#6

Actually, I could not reproduce it (I tried SDI and MDI modes). But I made Toad minimize stay on top windows before showing the “PC has Awakened” prompt, then restore them afterwards.