Toad World® Forums

14.1.114.917: Window for reconnection is invisible

Hello guys!

I've been using the current Beta for like two weeks now and discovered a consistent behavior:
Every morning when I wake my laptop from energy saving mode, the Toad Beta probably wants to show a window, hinting that the connection is disconnected, but the window is hidden somewhere.
I did not yet manage to make it appear, as every click somewhere only results in the hint sound being played and I cannot press any other button. I've tried pressing ALT+F4 to cancel the window, but nothing happens. Only thing I can do is to kill the program using the task manager (OS: Win10).

Maybe important: I work fom home and thus have a VPN connection. Maybe this plays into that?

Due to the window being completely invisible and the program being killed harshly, I cannot provide any more information.
Does anyone else have this problem, or can anyone confirm that there is a bug?

Edit: when I disconnect the VPN manually and then go to my Toad, the following window appears:
Screenshot 2021-03-25 071358

So I think this is the window that should also appear after I wake my computer. But unfortunately it is hidden.

This is the first time I have heard of this problem, but I will investigate.

I can do ALT+R to reconnect without clicking on the dialog, or ESC to cancel out, maybe one of those will work for you.

Do you see this window when your PC wakes up? If so, do you click yes or no?

image

Hi John!

Thank you for investigating this!
The dialogue you posted above has been appearing in older versions of Toad (i.e. 14.0 and the previous versions I used), but it did never appear while I was using the beta build.
Maybe it should be displayed and is hidden? I don't know which dialogue should appear, since it's always hidden or invisible.

I also haven't tried ALT + R (will do tomorrow), but I guess the outcome will be the same since the Toad ignores every input, starting from ESC all the way to ALT + F4 :smiley:
Only way out from this is killing the application via Task manager.

Also try Enter. If that dialog is the one that’s showing (but hidden) then Enter will click the Yes button.

I will try both tomorrow!
Also I'll try to make a GIF showing what I see and (cannot) do. :slight_smile:

I tried this several different ways today but was never able to reproduce it.
I tried with Toad maximized, not maximized
1 and 2 monitor configurations.
All on Windows 10.
For me, the dialog always appears.

Not sure what else to try. If you have any more info about your configuration that could be relevant, please let me know. Maybe also include a screen shot of what your desktop looks like before hibernation.

As a workaround, you can add this to your Toad.ini, under the [SETTINGS] line. This will cause Toad to not prompt you after your PC wakes up, and you can do the reconnect yourself by clicking Main Menu -> Session -> Test all connections.

WakeUpReconnectPrompt=1

Okay, here is what I did:

  • have a package checked out and opened in editor (in beta version)
  • have a Describe Objects window open (but minimized, in beta version)
  • have one or more other instances of Toad 14.0 running, also with Describe Objects windows open
  • after clocking out from work I just set the PC to hibernate, no VPN disconnect or so from me
  • how I left the Toad can be seen in the image below (notice the small frame for the minimized Describe window in the bottom left)

  • after resuming and logging on to Windows, I had other programs pop up in front (IntelliJ, Outlook login)
  • After clicking on the Toad Beta in the task bar, it opened in the state I described in previous postings.
  • I - unfortunately - did not make a screenshot of this, but I noticed a 2nd minimized window in the bottom left, to the left of the one that can be seen in the first screenshot
  • I maximized it and it was a Describe Objects window of another Toad instance (14.0) that I had open
  • after closing it and going back to the Beta Version I saw the reconnect window as it should be:

I don't know if this makes it such an edge case not worth any effort, but I hope the description is quite clear now and you can reproduce it? :slight_smile:

Either way, have a nice weekend!
greetings, Franz

Thanks for the details. It seems that something inside of Toad is attempting a query before "wake from sleep" prompt has a chance to appear. I'll try following your steps today.

Do you have this line in Toad.ini already? If so, try removing it.
WakeUpReconnectPrompt=1

I also have the reconnect dialog box behind the main toad window. This is not an issue for me as I can usually minimize toad and find the reconnect msg box. I do not hibernate my pc, however I destroy and recreate the schema in a sqlplus command that causes my issue. We have talked in the past about this issue. I am just saying this is not an isolated case(if my case is similar). I use pulse vpn

Good Morning!

Sorry I forgot about the ini file. The line WakeUpReconnectPrompt=1 was in it and I removed it for now. I'll report the behavior tomorrow.

I've been trying to reproduce the "reconnect dialog not in front" problem but without any luck. For me, it is always in front.

14.2 will have an option to automatically reconnect when connections are lost, so that may help here by preventing the "reconnect" window in the first place.

Too bad to hear... Nevertheless, thank you for your efforts!
I am looking forward to the automatic reconnect! :laughing:

Good Morning!
Sorry for the late reply!

Today after waking my laptop from hibernate I saw hthe following popup window in my Toad Beta (I removed the line WakeUpReconnectPrompt=1 already)

image

Good. And then "Ja" worked?

Yes, clicking on "ja" (yes in English) caused Toad to reconnect without any further issue. :slight_smile: