Toad World® Forums

Model can't be locked on Sync & Convert


#1

I have a MSSQL Phys model from which I’ve generated an MSSQL Database.

I then modified the Database and reverse engineered it for testing purposes.

I’m attempting to now sync my Phys model with the reverse-engineered Database.

Stepping through the Sync & Convert wizard and choosing Merge Models and selecting the reverse-engineered Database as source and my Phys model as target I get dialog box error:

“Model <my target model ie Model 2 (right side)> can’t be locked”

I’ve searched (and searched) for what ‘locked’ means with no result.

I’ve saved the project and all models etc.

Would appreciate advice on:

  1. what locked means
  2. why my Phys model can’t be locked
  3. how to avoid this roadblock in future

Cheers
Greg


#2

Hi Greg,

if you edit some object in your model and do not confirm the changes by cliking the Apply or OK button, the model waits for the confirmation and is in the “locked” state.

See attached screenshot. The entity Customer is open, name is modified but I didn’t confirm the change before opening the Sync & Convert Wizard. That’s why the model was still locked.

Confirm all changes in your models, save the models and then run Sync & Convert Wizard. If you are not sure what else needs to be done, restart TDM and then do the synchronization as the very first step.

Regards,

Vaclav


#3

Thanks Vaclav

Sync has succeeded.

On attempting to exit TDM I recsponed to popup dialog that indicated a model object (name was null, I didn’t take a screen capture but it wasn’t my target model) was not saved.

I chose to save the (un-named?) item and restart TDM.

On restart of TDM I ran Sync & Convert as first task and it worked as advertised :slight_smile:

I’m not sure how I managed to select the Sync & Convert wizard with uncommitted edits elsewhere; I’ll keep an eye out for similar behaviour.

Thanks for your speedy response - roadblock averted.

Greg


#4

Hi Greg,

thanks for the confirmation. I am glad it works fine.

Good luck,

Vaclav