Multiple Query Results for Toad

By the way, I saw an article in another post that this problem can be solved by opening it as New1, New2, New3. But this is not a solution because I cannot copy the Query to every tab. It's a workload. The feature you mentioned is available in Dbeaver. They have added this feature to their own programs, why not Oracle?

We actually just released this feature in beta today.

If you have Toad version 16.3, you can install the beta and try it. You can get the beta here: Toad for Oracle 17.0 Beta

Note: we don't have the ability yet to highlight multiple selects and run/pin them all automatically, but you can run one, pin the result, run the next, pin the result, etc. I plan to add the "run all" ability next.

Click here to pin the result

After that you get this:


Thank you for the quick reply. In fact, I think this can be fixed by using key combinations instead of manually pinning. So those who don't want to have pins just CTRL + ENTER, those who want to have automatic pins CTRL + SHIFT + (><| button). I think this is more practical.

I think you should also consider the suggestion I mentioned. have a nice day

Which button are you referring to here? Can you post a screen shot?

Edit: Oh, I guess a button in DBeaver.

no, the key i'm talking about is on the keyboard

the button I mentioned that I will mark and send

1 Like

I just installed DBeaver to try it out. The shortcut is nice, but for me, it's different. Mine is CTRL+\. Did you change yours or know why mine is different?

Dbeaver is not installed on my current computer. Because of this, I can't install and try Dbeaver again. But until a month ago, I was using it with the keys I mentioned above. If you have these buttons on your keyboard, can you try?

By the way, isn't the shortcut I'm talking about beautiful :slight_smile:

I agree that it's a nice shortcut. I don't have the exact key you mentioned on my keyboard. For me, <, >, and | are all on different keys. I tried CTRL+Shift with each of them in DBeaver and they did different things (or nothing)

CTRL+\ is nice though. I'll add that to Toad for "Run SQL and Pin". Shortcuts in Toad are programmable so you can change it to your preferred keystroke if you want.

Thanks for your interest, I hope this feature comes soon and we use it. enjoy your work

Version 17.0 is expected to be released next month.

If you have Toad version 16.3, you can get the beta now if you want from here.

The beta will be updated on Monday and the shortcut will be in it.

I do not fully understand. I am currently using 16.0. Should I wait for version 17.0 for the feature I mentioned above?

If you can upgrade to 16.3 now, then you can get the beta and start using this feature now in beta. (Beta will only work if you have 16.3 installed.)

If you cannot upgrade to 16.3 now, or are not allowed to get beta version (some companies restrict beta software usage), then you can get version 17.0 when it comes out in October.

Hi @JohnDorlon , Has the 17.0 version you mentioned been implemented?
Because my company does not allow using Beta versions

Not yet. Version 17.0 will be released around the end of October.

Hi @JohnDorlon .
Thanks for the development. I installed. But what is the shortcut for these multiple results? I tried many times but couldn't find it. Can you share the correct shortcut?

The default shortcut to execute the sql and pin the grid is supposed to be CTRL+\
Or, to pin a grid for which you already ran the sql: CTRL+Alt+P

I don't know why the CTRL+\ shortcut isn't there for you, but you can set it here:

Hi @JohnDorlon
I did it as you mentioned and it works. It's a great development. Congratulations to you.
I would like to give you feedback on a few minor issues. Maybe you may want to improve on this issue as well.

1- When I execute a query normally, it opens as a tab named "Default". Then, when I execute "Execute statement and pin data", the tab open as "Default" is reset. Data disappears.
In other words, when I first execute normal and then do pin data, the data in the first data tab should not be deleted.

2- When I execute a query with a semicolon at the end normally, the query works. But when I execute it with pin data, it doesn't work. Because there is no semicolon at the end it gives an error. Finally, I should be able to execute queries without semicolons with pin data.


Hi Furkan,

  1. When the data is pinned, what happens behind the scenes is that we create a pinned tab, and move the the query result and grid to the new tab. Data does not disappear, it is moved. If you want to see data on both tabs, hit F9 after you pin to run the query again.

  2. Generally that requires that you end your SQL with semicolon if you have multiple statements in the editor. If you want a blank link to count as a delimiter between SQL, try checking this option:

Yes, I did what you mentioned. I love Toad now. It was a very nice development. Thank you again to you and your team. I hope everyone will be happy with these improvements.

Best Regards

1 Like