Toad World® Forums

New to Toad 3.2 - teething problems

I’m trying to move from RapidSQL to Toad 3.2 and struggling with a couple of things.

1 - How do I show the results of a script that has multiple sets of results. I just want to scan down each set of results quickly. Rapid sends it all to one results pane and does its best to creating suitable colunm widths. It seems I can only show one result set at a time in the Toad Results pane and this is a real drag having to move to each result set separately.

2 - The Execute icons are grayed out in version 3.2.0.916 when I open files that don’t have a .sql suffix. I have hundreds of files with varying suffices that have SQL in them that I want to be able to execute. If I open the same files in Toad 3.0.1.1734 the execute icon is not grayed out. I’ve found a way round this by opening a SQL Editor and then pasting the code into it but this isn’t practical given the number of files I have to work with on a dily basis. I can’t find a setting anywhere that allows me to associate file suffixes with the SQL editor

  1. I have scripts that create #temporary tables. In Rapid these #tables are removed automatically when the script completes. In Toad, if I run the script again it complains because the #tables are still there. I don’t really want to chang all my scripts just to drop #tables - is there a way to tell Toad to drop them after each execution as in Rapid?

Thanks

RE 1: I can recommend two different ways to look at multiple results. If you run a script using F5 the results will be stacked. See image.

You can also go to the message tab and choose the text and include results. This will put all results as text. See image.

RE 2:That issue is fixed in TDP 3.3.

RE: 3: We do not have this feature. The editor uses the same connection so you would need to close and reopen the connection or use a different editor.

Debbie

Of the 3 questions I asked, one is a bug that requires me to upgrade (execute is grayed out on files without a .sql suffix – fixed in 3.3) – upgrades are out of my control so I’m stuck with it not working for now.

The second question was about #tables not being cleared up after running a script. This is because Toad keeps a connection open. To get round this I now have to change all my scripts so that they manually remove #tables. Toad is forcing me to change my code. This isn’t very desirable. It would be better perhaps to have an option to chose to close or re-establish the connection. The solution is to close the editor and reopen it in order to run it. Again, overhead I don’t need.

The third question was about seeing multiple result sets in the same window. Debbie has offered a solution for this – something I had already tried. Unless I’m doing something wrong, it doesn’t work on my Toad. I have set the output to text and asked it to include results – I don’t get any results in the message tab when I do this.

Thanks

Aaron

For item three, please state what version you are using and post a screenshot of what you are trying.

An answer for the second question. You can add this code to delete your table.

/* DROP THE TABLE IF IT EXISTS. */

BEGIN

EXECUTE IMMEDIATE ‘DROP TABLE SCHEMA.Tablename PURGE’ ;

EXCEPTION

WHEN OTHERS THEN

IF SQLCODE != -942 THEN

RAISE;

END IF;

END;

COMMIT;