Toad World® Forums

New pick-list dropdown does not select first item

I usually type until my desired method is the first in the list and then press ENTER to confirm it.

This worked with 11.7 but the new dropdown does not select the first entry, so I need to press cursor down before ENTER.

Could this behavior please be re-implemented? Thanks!

For next beta hitting enter accepts the first visible item. For now the first item is still not visually selected.

Auto selection of the first item is a little more problematic now because the list is populated by multiple threads. I don’t know if an executing thread will return results and when results are returned sorting may change the first visible item so the auto-selected node must be updated. While results are fetching you may also manually select an item which should be retained. I’ll return to visualizing the selection later as time permits, but hitting enter without manually selecting a node will work as it always has.

Thank you, that should be sufficient for now.