Toad World® Forums

No valid Oracle clients found. You need at least one 32-bit client properly configured


#1

I have a working 32-bit Oracle client installed on a Windows server and a Toad 32-bit client installed on the same machine. When I open the Toad client, I get this error message:

No valid Oracle clients found. You need at least one 32-bit client properly configured.

Despite this error message, I do have a working 32-bit Oracle client, meaning Sqlplus is working correctly, SQL Developer is working correctly, etc.
Is there a way to explicitly tell the Toad client where the Oracle client is located?
Anything else I need to check?

Thanks!


#2

It should “just work”. Is the folder with OCI.DLL in your system path? If not, add it.


#3

Oracle client bin directory is first directory listed in PATH so that should be OK.
Is there anything in the registry to check?
Is it a problem that the Oracle client is installed on D drive and Toad client is on C drive?


#4

You shouldn’t have to edit the registry. Oracle does that when you install it. C/D should be OK too. As long as your user can access both locations. Does it help if you run as admin?

What are your Toad and Oracle client versions?


#5

Running as admin.
Oracle is 12.1.0.2 32-bit.
Toad is Toad for Oracle Professional 13.0.0.8.0 32-bit


#6

Not really sure what to suggest besides the obvious:

  1. make sure your oracle client is 32 bit. Easiest way is to start sql*plus, then go to task manager. Find it on the Processes tab. If it has a *32 after it, it’s 32 bit. Otherwise, 64 bit.

  2. If that checks out, re-download (as a sanity check) and reinstall the oracle client.

You can have multiple clients installed. Toad will let you choose which one to use (only the matching bit ones will be a choice)


#7

I’m absolutely positive both are 32-bit.
We’re going to uninstall everything and reinstall and see what happens.
Thanks for the input!


#8

If you still have problems, send me the download link that you are using (sometimes they have clients bundled with other stuff) and I’ll give it a try too.


#9

I deinstalled everything, cleaned the registry and the path, rebooted, reinstalled Oracle with admin privs, tested Sqlplus and SQL Developer successfully. Tried to install Toad with admin privs and got this:

The install file I used was downloaded on the machine by someone else:
Toad_for_Oracle_2018_x86_Full.exe


#10

Does it matter which type of Oracle client is used, i.e., Admin, Runtime, Custom, etc.?


#11

I tried installing the Oracle 11g 32-bit client and Toad had no problem with that.


#12

I always go with admin, but I don’t think it matters as far as connectivity with Toad.

I meant the download link for the Oracle client, but I don’t need it if you are happy now.

I use the 32 bit Oracle 12.1.0.2 client. so I’m not sure why it didn’t work for you. weird.