"Number AS Text" getting copied as number in excel

Hi Team, My oracle table has column with "Number AS Text" examples 000001000 or 000001567 but when I am copies the values and pasting it in excel they are getting pasted text 1000 and 1567 instead of 000001000 and 000001567 respectively. Please advise if I need to change any settings in Toad.

Excel does that. You can get the same result copying the the values from notepad to Excel.

The only workaround is to send the data with a single quote in front of it.

To do that, in Toad, use Export Dataset, not copy to clipboard. Choose the options that I highlighted in yellow. If you want the data to go to a particular place in Excel, check the option that I highlighted in green. Otherwise, it will go to a new sheet in Excel.

1 Like