Toad World® Forums

Keeping Number Data Types From Becoming Text Data Type When Exporting to MS Access

Got a new laptop and TOAD is now exporting double number formats as short text.
Old computer kept double number data type but new computer overwrites to new tables when exporting as Short Text format.
For example, our customer id numbers are 10 digit numeric (double, not long integer). When exported to MS Access, the data type is Short Text.
Old computer was Windows 7 and Toad for Oracle 10.6.1.3.
New computer is Windows 10 and Toad for Oracle 12.10.0.30
I dread having to convert all my files impacted. Is there a Toad Option to keep numbers as numbers when exporting?

make sure you have the “display numbers in scientific notation” option checked.

Yes it worked. I went to the View menu and then to Toad Options and checked the Display large numbers in Scientific Notation. This changes the exporting to Access behavior. Ten digit numbers now stay as numbers instead of text. My currency fields are now exporting correctly as numbers instead of as text. It is odd that Toad for Oracle 10.6 behaved correctly even without this checkbox being checked.

It was a bug. Not sure how or when it got introduced. 10.6 was a long time ago. I fixed it for the next release.