Toad World® Forums

Number Format changes when clicking cell to copy/edit

Is there a way to keep the program from applying a format to numbers in the query grid when I click on them?

Very annoying “feature”. Have several fields with long ID numbers and such. When I click on one of these on a query grid to copy to the clip board to use in the criteria for another query, TDA applies a format to the cell… ie. 456231656 becomes 456,231,656. and the commas go to the clip board along with the rest of the number. I’m constantly having to remove the commas when pasting the numbers in as criteria in a query. The commas aren’t there when viewing the grid. They do not appear until you click into the cell to select the data. Weird.

I’ve tried changing several things in the options, but apparently haven’t found the correct one if it exists. Is there a way to turn the feature off? Any help would be appreciated.

Michael,

Someone else may have a better idea, but I’ve noticed if I just click into the cell, hit Ctrl+C, and paste, I don’t have the formatting you’re describing. However, if I’ve clicked into the cell and highlight the data, I will have that formatting when I copy/paste. Would you mind trying to just click into the cell and then just ctrl+C and ctrl+V to see if the formatting goes away?

By the way, I’m doing this with 2.0 of the product.

Ben

Bump. I use Toad for MySQL 6 beta, and it does the same thing. :frowning:

All data type formats are customizable in the Options | environment. See screenshot.

Debbie

So how do you remove comma delimits from doubles? The dialog is very much not self-explanatory.

Here is a sample format string. Put it in the custom section.

$######.00

Debbie

I put ############# in the custom section with format type numeric and a random type name, and oddly enough I still have commas in all of my doubles which are luckily that exact number of characters or else who knows what.

Maybe I need a real type name like “double” or decent contextual help.

I am not getting this behavior. What type of connection are you using? Oracle, Sql Server, etc. And what is the datatype of the column you are using? I want to replicate this issue here.

Debbie

It is MySQL and doubles.

I see this now. It seems to be unique to the mySQL provider. I happen to being working on a demo and using mySQL yesterday and ran into this issue and got annoyed myself. I can’t seem to find a work around as the Data Grid doesn’t seem to be paying attention to the format options.

I entered CR90783 to fix. It will not make it into 3.0 but we will get to it

Thanks,

Debbie

I also have an issue when attached to an Oracle DB using an ODBC connection, e.g. number field in Oracle DB reads 919704096 in the results window of Toad for Data Analysts 3.0, I get either the scientific notation, 9.197041E+08 when using any of the choices listed except for the following results:
919704100 when trying to use a Custom - #
919,704,100.00 when using Number
919704100.00 when using Fixed-point

For Oracle use the natvie connection, not ODBC.

Debbie