Toad World® Forums

Object browser detail pane shows column names with junk characters

Hi All,

When i try to view table data from schema browser i get a strange error msg as in screen shot. It seems that toad is appending some junk characters to column names and they give error.

Please note that the same data is visible with sql developer or any other tool. I dont see any junk characters when in click script option in detail pane. It only shows in columns tab as shown in screen shot.

Any help would be greatly appreciated as its very annoying. I already tried dropping table and recreating it. But no help

Looks like it might be an NLS and/or Unicode issue. If so then that would make it a setup/config issue and not a Toad problem. Suggest reading/watching these
blogs/videos as a start:

http://www.toadworld.com/platforms/oracle/b/weblog/archive/2009/06/01/what-is-unicode-part-1.aspx

http://www.toadworld.com/products/toad-for-oracle/b/weblog/archive/2009/06/08/what-is-unicode-part-2.aspx

http://www.toadworld.com/products/toad-for-oracle/b/weblog/archive/2010/09/15/identifying-the-source-of-potential-unicode-issues-in-toad-174-for-oracle.aspx

http://www.toadworld.com/products/toad-for-oracle/m/media-library/296.aspx

I have seen old Oracle clients cause this problem. If you are using a 9i or 10g client, try installing a newer one.

From: tusharghotikar [mailto:bounce-tusharghotikar@toadworld.com]

Sent: Friday, September 13, 2013 5:10 AM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] Object browser detail pane shows column names with junk characters

Object browser detail pane shows column names with junk characters

Thread created by tusharghotikar

Hi All,

When i try to view table data from schema browser i get a strange error msg as in screen shot. It seems that toad is appending some junk characters to column names and they give error.

Please note that the same data is visible with sql developer or any other tool. I dont see any junk characters when in click script option in detail pane. It only shows in columns tab as shown
in screen shot.

Any help would be greatly appreciated as its very annoying. I already tried dropping table and recreating it. But no help

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Thanks Bert, I changed my local machine nls_lang character set and its working now.

@ Bert, yes i am using old oracle client too…but after changing nls_lang setting its working. Thanks for ur help.

Glad I had a right answer for a change
J

From: tusharghotikar [mailto:bounce-tusharghotikar@toadworld.com]

Sent: Friday, September 13, 2013 8:19 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Object browser detail pane shows column names with junk characters

RE: Object browser detail pane shows column names
with junk characters

Reply by tusharghotikar

@ Bert, yes i am using old oracle client too…but after changing nls_lang setting its working. Thanks for ur help.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Small advice.

Capture Toad command (Spool option) and then perform same sql in sqlplus. If there is no error then it is probably Toad problem.

Otherwise, monkey is in Oracle yard …

@ tusharghotikar What did you do to change your local machine nls_lang character set to and how did you do that?

Thanks

Dave

The 2nd link that Bert provided in the thread answers your question on what NLS_LANG is and how to set it. Give it a read and let us know if you figure it
out:

http://www.toadworld.com/products/toad-for-oracle/b/weblog/archive/2009/06/08/what-is-unicode-part-2.aspx

From: dozier93 [mailto:bounce-dozier93@toadworld.com]

Sent: Tuesday, October 08, 2013 9:54 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Object browser detail pane shows column names with junk characters

RE: Object browser detail pane shows column names with junk characters

Reply by dozier93

@ tusharghotikar What did you do to change your local machine nls_lang character set to and how did you do that?

Thanks

Dave

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

I have also seen this problem solved in the past just by installing a newer version of Oracle client (especially if your is early 10g or older)

From: Mark Lerch [mailto:bounce-Mark_Lerch@toadworld.com]

Sent: Tuesday, October 08, 2013 9:47 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Object browser detail pane shows column names with junk characters

RE: Object browser detail pane shows column names with junk characters

Reply by Mark Lerch

The 2nd link that Bert provided in the thread answers your question on what NLS_LANG is and how to set it. Give it a read and let us know if you figure it
out:

http://www.toadworld.com/products/toad-for-oracle/b/weblog/archive/2009/06/08/what-is-unicode-part-2.aspx

From: dozier93 [mailto:bounce-dozier93@toadworld.com]

Sent: Tuesday, October 08, 2013 9:54 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Object browser detail pane shows column names with junk characters

RE: Object browser detail pane shows column names with junk characters

Reply by dozier93

@ tusharghotikar What did you do to change your local machine nls_lang character set to and how did you do that?

Thanks

Dave

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Image removed by sender.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.