Toad World® Forums

ORA-06413 after upgrading Windows 7

ORA-06413 after upgrading Windows 7

Morning,

Can you help understand what and how those settings are to
be checked (Environment variables and registry settings) ?
Thanks in advance.

Check:

ORACLE_HOME
NLS_LANG

Both as environment variables or in the registry
settings for this latest installation.

Ok, crack open a dos box and:

echo %ORACLE_HOME%
echo %NLS_LANG%

If you get anything back for these, then you have (or have had) them set
in control panel.

If you get nothing back, run regedit and go to HKLM/software/oracle
then, for each HOMEn listed, check to see if there is an entry there for
either of these two variables.

And one last thing, as Roger pointed out, you are using Windows 7 with
an Oracle 8.0.6 client. Two problems here:

  1. 8.0.6 client is totally unsupported by Oracle;
  2. 8.0.6 client existed long before Windows 7 - it may not be
    compatible.
  3. 8.0.6 client only allows connections up to database versions 9.2.x.

(Ok, three problems!)

I’m wondering if Windows 7 has put your client into a path that has
spaces or punctuation in it? If so, Oracle client (at least as far as
10g) doesn’t like that idea and fails to work properly./

Where did you install the client into?

Cheers,
Norm. [TeamT]

Norman Dunbar
Contract Senior Oracle DBA
Capgemini Database Build Team
Internal : 7 28 2051
External : 0113 231 2051

Information in this message may be confidential and may be legally privileged. If you have received this message by mistake, please notify the sender immediately, delete it and do not copy it to anyone else.

We have checked this email and its attachments for viruses. But you should still check any attachment before opening it.
We may have to make this message and any reply to it public if asked to under the Freedom of Information Act, Data Protection Act or for litigation. Email messages and attachments sent to or from any Environment Agency address may also be accessed by someone other than the sender or recipient, for business purposes.

If we have sent you information and you wish to use it please read our terms and conditions which you can get by calling us on 08708 506 506. Find out more about the Environment Agency at www.environment-agency.gov.uk

And maybe there is another problem? 32 bits or 64 bits. There are several Oracle
clients which give problems under 64 bits, where programs installed in a
directory with parenthesis in the directory name give problems. And Toad is
installed into C:\Program Files (x86)\Quest Software\Toad for Oracle… in
a Windows 7 64 bits edition. The problem is that the application (Toad) cannot
connect to Oracle due to a bug in the Oracle client. In version 10.0.4.0 and
higher this is solved.

Groetjes,
Wim

On Mon, Sep 26, 2011 at 11:17, Dunbar, Norman (Capgemini)

wrote:

Morning,

>> Can you help understand what and how those settings are to
>> be checked (Environment variables and registry settings) ?
>> Thanks in advance.

>> >> Check:
>> >>
>> >> ORACLE_HOME
>> >> NLS_LANG
>> >>
>> >> Both as environment variables or in the registry
>> >> settings for this latest installation.

Ok, crack open a dos box and:

echo %ORACLE_HOME%
echo %NLS_LANG%

If you get anything back for these, then you have (or have had) them set
in control panel.

If you get nothing back, run regedit and go to HKLM/software/oracle
then, for each HOMEn listed, check to see if there is an entry there for
either of these two variables.

And one last thing, as Roger pointed out, you are using Windows 7 with
an Oracle 8.0.6 client. Two problems here:

1. 8.0.6 client is totally unsupported by Oracle;
2. 8.0.6 client existed long before Windows 7 - it may not be
compatible.
3. 8.0.6 client only allows connections up to database versions 9.2.x.

(Ok, three problems!)

I'm wondering if Windows 7 has put your client into a path that has
spaces or punctuation in it? If so, Oracle client (at least as far as
10g) doesn't like that idea and fails to work properly./

Where did you install the client into?

Cheers,
Norm. [TeamT]

Norman Dunbar
Contract Senior Oracle DBA
Capgemini Database Build Team
Internal : 7 28 2051
External : 0113 231 2051

Information in this message may be confidential and may be legally
privileged. If you have received this message by mistake, please notify the
sender immediately, delete it and do not copy it to anyone else.

We have checked this email and its attachments for viruses. But you should
still check any attachment before opening it.
We may have to make this message and any reply to it public if asked to
under the Freedom of Information Act, Data Protection Act or for litigation.
Email messages and attachments sent to or from any Environment Agency
address may also be accessed by someone other than the sender or recipient,
for business purposes.

If we have sent you information and you wish to use it please read our terms
and conditions which you can get by calling us on 08708 506 506. Find out
more about the Environment Agency at www.environment-agency.gov.uk

OK. I got this worked finally… The original installation by admin team
happens to C:\Program Files (x86). I performed couple of steps and was able to
succeed.

1.  Right click on the Quest Software folder under C:\Program Files

(x86), and select the Move to Folder… option. Selected the destination
folder as C:\Program Files (or any other) and that’s it. I have to
additionally change the shortcuts pointing to the appropriate location
2. With # 1 working, I requested an install in a different location
(other than C:\Program Files (x86)) and it worked too…

Backend is Oracle 9.2 still.

Thanks Norm / Wim and everyone, for all the pointers.

Regards,
N. Selvam.

On 9/26/2011 2:51 PM, Wim de Lange wrote:

And maybe there is another problem? 32 bits or 64 bits. There are several
Oracle clients which give problems under 64 bits, where programs installed
in a directory with parenthesis in the directory name give problems. And
Toad is installed into C:\Program Files (x86)\Quest Software\Toad for
Oracle....... in a Windows 7 64 bits edition. The problem is that the
application (Toad) cannot connect to Oracle due to a bug in the Oracle
client. In version 10.0.4.0 and higher this is solved.

Groetjes,
Wim

On Mon, Sep 26, 2011 at 11:17, Dunbar, Norman (Capgemini) <
toad@dunbar-it.co.uk > wrote:

    Morning,

    >> Can you help understand what and how those settings are to
    >> be checked (Environment variables and registry settings) ?
    >> Thanks in advance.

    >> >> Check:
    >> >>
    >> >> ORACLE_HOME
    >> >> NLS_LANG
    >> >>
    >> >> Both as environment variables or in the registry
    >> >> settings for this latest installation.

    Ok, crack open a dos box and:

    echo %ORACLE_HOME%
    echo %NLS_LANG%

    If you get anything back for these, then you have (or have had) them set

    in control panel.

    If you get nothing back, run regedit and go to HKLM/software/oracle
    then, for each HOMEn listed, check to see if there is an entry there for

    either of these two variables.

    And one last thing, as Roger pointed out, you are using Windows 7 with
    an Oracle 8.0.6 client. Two problems here:

    1. 8.0.6 client is totally unsupported by Oracle;
    2. 8.0.6 client existed long before Windows 7 - it may not be
    compatible.
    3. 8.0.6 client only allows connections up to database versions 9.2.x.

    (Ok, three problems!)

    I'm wondering if Windows 7 has put your client into a path that has
    spaces or punctuation in it? If so, Oracle client (at least as far as
    10g) doesn't like that idea and fails to work properly./

    Where did you install the client into?

    Cheers,
    Norm. [TeamT]

    Norman Dunbar
    Contract Senior Oracle DBA
    Capgemini Database Build Team
    Internal : 7 28 2051
    External : 0113 231 2051

    Information in this message may be confidential and may be legally
    privileged. If you have received this message by mistake, please notify
    the sender immediately, delete it and do not copy it to anyone else.

    We have checked this email and its attachments for viruses. But you
    should still check any attachment before opening it.
    We may have to make this message and any reply to it public if asked to
    under the Freedom of Information Act, Data Protection Act or for
    litigation. Email messages and attachments sent to or from any
    Environment Agency address may also be accessed by someone other than
    the sender or recipient, for business purposes.

    If we have sent you information and you wish to use it please read our
    terms and conditions which you can get by calling us on 08708 506 506.
    Find out more about the Environment Agency at
    www.environment-agency.gov.uk