Toad World® Forums

ORA-12075 Invalid/Unknown NLS parameter

Hello. I’m not sure if this is really a TOAD issue, but I’ve tried other sources without success.
A colleague is trying to install TOAD (9.7) onto a virgin PC.
He gets the Connect screen up, it finds the correct TNSnames.ora file, but when he tries to connect to a database, the above error is shown.

There’s nothing obvious in the toad.ini file, can anyone offer some advice?
Thanks!
Jason

Hi Jason,

Under start->Programs->Quest Software->Toad For Oracle->Tools you should
find SQL Monitor or SQL Tracker. Start this up AFTER toad is running but
BEFORE selecting a database to connect to.

In the list of running applications in SQL Monitor, select Toad, and
click the button to start monitoring.

In Toad, attempt to connect to the database in question.

Watch SQL Monitor’s output. When it appears to have stopped, Save the
output to a file BEFORE you stop monitoring Toad. (I think at 9.7
stopping monitoring clears the output!).

Turn off monitoring of Toad.

Now, you can have a look at the monitor output, safely saved in a file,
to see if you can find the problem, or past the output into an email
(some attachments don’t get transmitted) and send it here.

I’ve just run it with Toad 10.6GA, an Oracle 10g client and an Oracle
10.2.0.1 database, and at no point can I see Toad attempting to set NLS
parameters, lots of reading of them though.

Good luck.

Cheers,
Norm. [TeamT]

Norman Dunbar
Contract Senior Oracle DBA
Capgemini Database Build Team
Internal : 7 28 2051
External : 0113 231 2051

Information in this message may be confidential and may be legally privileged. If you have received this message by mistake, please notify the sender immediately, delete it and do not copy it to anyone else.

We have checked this email and its attachments for viruses. But you should still check any attachment before opening it.
We may have to make this message and any reply to it public if asked to under the Freedom of Information Act, Data Protection Act or for litigation. Email messages and attachments sent to or from any Environment Agency address may also be accessed by someone other than the sender or recipient, for business purposes.

If we have sent you information and you wish to use it please read our terms and conditions which you can get by calling us on 08708 506 506. Find out more about the Environment Agency at www.environment-agency.gov.uk

In the Toad login screen, click the … button next to the “connect using” dropdown. What is the value for NLS_LANG?

Thanks guys. I’ve tried your suggestions but not sure if they help much…

NLS_LANG is currently set to
ENGLISH_UNITED KINGDOM.US7ASCII
but we’ve also tried
ENGLISH_UNITED KINGDOM.WE8ISO8859P1
AMERICAN_AMERICA.WE8ISO8859P1

  • which haven’t helped.

The SQL Monitor log showed:

Logon attempt failed. username: ‘TAROT’; database: ‘TARPRDM.WORLD’

Is it possible that you have a bad NLS_LANG environmental variable?

I’m out of ideas. At this point I would suggest contacting Quest support or at least searching support link for this error.

Go to the knowledge base tab here: https://support.quest.com/Search/ProductInformation.aspx

Thanks,
Brad

Hi Jason,

As other suggested, the most likely cause for this error is an invalid
NLS_LANG, which can be set in the registry, but also as an environment
variable.
Another possibility I think, though less likely, is that the directory
where your language files are located is not accessible. You don’t tell
what Oracle client you have installed, but a common place for these
files would be ORACLE_HOME\nls\data.

regards,
Peter

BTW It might be useful to use the right error-message. It is 12705, not
12075.

Op 29-9-2011 15:31, {Toad for Oracle} on behalf of
{jasonclements_1239185392328} schreef:

Forum: Toad Commercial Discussion

Hello. I’m not sure if this is really a TOAD issue, but I’ve tried other sources without success.
A colleague is trying to install TOAD (9.7) onto a virgin PC.
He gets the Connect screen up, it finds the correct TNSnames.ora file, but when he tries to connect to a database, the above error is shown.

There’s nothing obvious in the toad.ini file, can anyone offer some advice?
Thanks!
Jason

BTW Did somebody already suggest to test the connection with sqlplus?

Peter

Op 29-9-2011 15:31, {Toad for Oracle} on behalf of
{jasonclements_1239185392328} schreef:

Forum: Toad Commercial Discussion

Hello. I’m not sure if this is really a TOAD issue, but I’ve tried other sources without success.
A colleague is trying to install TOAD (9.7) onto a virgin PC.
He gets the Connect screen up, it finds the correct TNSnames.ora file, but when he tries to connect to a database, the above error is shown.

There’s nothing obvious in the toad.ini file, can anyone offer some advice?
Thanks!
Jason

Morning Jason,

Thanks guys. I’ve tried your suggestions but not sure if they help much…

NLS_LANG is currently set to
ENGLISH_UNITED KINGDOM.US7ASCII
This is most probably wrong! Remember NLS_LANG must represent the
territory and language on the client (Morning Mark!) not some arbitrary
value chosen to potentially match the database.

Look in Control Panel -> Regional Settings and report back your settings
for the following (on the General) tab:

Your locale: Mine is “English (United Kingdom)”.
Your Language Settings: Mine is “Western Europe and United States” and
is set to be the default, but I have no others ticked.

This gives me the following for my NLS_LANG settings for all my client
installs:

9.2.0.8: ENGLISH_UNITED KINGDOM.WE8MSWIN1252
10.2: ENGLISH_UNITED KINGDOM.WE8MSWIN1252
11.1: ENGLISH_UNITED KINGDOM.WE8MSWIN1252

All my client installs have defaulted the settings as above, based on
what was in my Regional Settings at the time of the install - I assume!

Can you check the Regional Settings on your desktops which work and
compare them to the one which doesn’t work.

in addition, someone (Peter I think) asked about using SQL*Plus (from
the same Oracle Home) to connect - does that work? If so, try selecting
from V$NLS_PARAMETERS as follows:

set lines 100
set pages 1000
col parameter format a30 wrap
col value format a30 wrap
select * from v$nls_parameters;

Thanks.

Logon attempt failed. username: ‘TAROT’; database: ‘TARPRDM.WORLD’
Runtime error occurred: 12705 (ORA-12705: invalid or unknown NLS parameter
value specified)

-which is no news :frowning:
Interesting that the monitor didn’t pick up on anything NLS being sent
to the database at logon time. (For certain values of “interesting”!)

We’re using Oracle client 9.2, which I know is out of date (it’s a 10g
database) but it works fine on all our other installations here.
Well, I’m mostly using 9.2.0.8 client to talk to 10g and 11g databases
and unless I try something funny like selecting from dba_scheduler_%
views where timestamp with timezones live, it just works. 9.2 client
doesn’t seem to like those pesky TS+TZ data types!


Cheers,
Norm. [TeamT]