Toad World® Forums

ORA-28513: y ORA-02063:

Hi,

I have an Oracle Database, connected with other Databases (Oracle/Informix), already have two DBLinks to Informix, and when I want to create a new one, in the server says Successfully connected but in Toad in the DBLink section shows:

ORA-28513: internal error in heterogeneous remote agent
ORA-02063: preceding line from "DBLink"

Any thoughts? Could you help me?

It could be that Toad is trying to run some query that only works with DB Links connected to Oracle.

What happens if you just try to use your DB LInk in the editor? Or in SQL*Plus?

Since is a DBLink (Database in another Server), how I could run it from the editor or sqlplus?

select * from table@Name_of_your_db_link

The DBLink is created but is not working due that errors, I have the other DBLinks with queries like that

I think something is set up wrong on your Oracle server or the transparent gateway installed there, but I don't know enough about DB Links from Oracle to Informix to tell you more. I don't think it is a Toad problem.

Thanks a lot John, the strange thing is that we have another connections like that working, but yes maybe the configuration is wrong, need to still looking whats going on

Did you find or create a gateway trace file? That should hopefully give you a clue. A quick check on Metalink (oops, My Oracle Support) says that this is caused by an error in the gateway init file. Usually HS_LONG_PIECE_TRANSFER_SIZE, for which the followingbadvice is given:

To use HS_LONG_PIECE_TRANSFER_SIZE parameter , you must use KB as size .

So it is better to have:
HS_LONG_PIECE_TRANSFER_SIZE=1024

rather than:

HS_LONG_PIECE_TRANSFER_SIZE=1MB

Disclaimer: I'm not a gateway expert, nor do I play one on TV. :wink:

Cheers,
Norm. [TeamT]

1 Like

I believe that if you Add the following to the gateway init<sid..ora file:

HS_FDS_TRACE_LEVEL=debug

and run the problem statement from a new session, you will get a trace file.

It is not necessary to stop and start the listener for this to take effect.

HTH

Cheers,
Norm. [TeamT]

Thanks a lot Norm, let me try