Toad World® Forums

Oracle Execute is not working

I have a customer who is using Toad for Oracle and we cannot get the button which runs Oracle Execute (the button with the lighting strike, which is not striking at all!) to run executes.

The user is on a Vista Enterprise client.

Enclosed is a screen shot. Everything else seems to be running fine.

HELP!!!!

What actually happens when you hit F5 – do you get any sort of error?

Can you run whatever you’re trying to run via SQLPlus? F5 (the lightning bolt)
is designed to emulate SQL
Plus functionality so as a general rule, if it works
there, it will work with F5. You can test it with the same button – it has
a dropdown item for Execute via SQL*Plus.

Greg

Are you using the highlighted button? The lightning strike alone is for PL/SQL
execution. The tooltip for the button should read “Execute PL/SQL…” If you are
correctly using the highlighted button then refer to the other comments.
image001.png

Thank you for your responses!!

No, nothing happens and no errors are thrown.

I am checking with the user now for the rest of your questions, again, THANK YOU!

Thanks for your responses, again. Here are the user’s replies:

Can you run whatever you’re trying to run via SQL*Plus? F5 (the lightning bolt)
“Yes I do. Even pressing F5.”

“What is does not work is if I use the pull down in lightning bolt (lightning bolt>Execute in SQL*Plus)”

“I like this option because allows me to open a TAB per execution, allowing me to execute multiple queries/TABS.”

IS THERE SOME KIND OF PERMISSION THAT I AM MISSING IN ASSIGNING THE USER?

The only other reason I can think of for Execute Script (F5) to be disabled is
if Toad is read-only. Is Toad security setup on your DB, and if so, does this
user have the read-only restriction applied? Check for the TOAD schema on your
DB and if it’s there, can you logon as Toad and check Toad security
settings? Does this user have a read-only version of Toad? Go to database >
create, is everything available there? (assuming you have a DB connection).