Toad World® Forums

Oracle Login Box when opening a file.

Hello,

I was wondering if someone could tell me where the setting is that tells NAV to give me the Oracle Logon box to connect to to a database when I double click an .sql file. This used to happen for me, but I believe some setting has changed since my upgrade to 6.2.1.

Thanks in advance for your help.

Reggie
SQL Navigator 6.2.1 Standard Edition

PS1964.jpeg

Hi Reggie,

Unfortunately, this is a bug in 6.2.1. It has been targeted to be fixed in 6.4.

Gwen

We’ve just upgraded from SQL Navigator 5.5 to 6.4.0.1930, and are no longer able to double click on an SQL file and go to the Oracle Login Box. We use the LDAP option. Was this fixed in 6.4? If so, what’s the option?

Thanks

Hi Jerry,

You can do the the .sql file ext ssociation with SQL Navigator 6.4 in the Preference window.

Go to Main menu View->Preferences. Click the 'Assoc.' button (bottom row of buttons), you will get an option to select whether you want to open files using the same SQL Navigator instance.

Please let us know if that would work for you.

Thanks,
Bruce

Hi Bruce,
I tried using your instructions but now it is skipping the logon screen altogether instead of just showing it on the first file I open. On the assoc button I answered yes to the first question and no to the second, then I hit apply and then OK. I have also tried answering yes to both questions under the assoc button and got the same result.

Hi Delores,

Sorry for a late reply.

When I sent you an reply earlier, I did some testing using v6.5, and could reproduce same issue you reported, but I did not realized that I have the preference 'Show Logon Dialog on startup" set to OFF. I have removed my last note as i could confirm that it worked as expected.

Could you please check your preferences and make sure the option is selected as attached screen shot. (Preference window can be open from main menu View->Preferences). When having it on, you should get the logon window everytime you try to load the sql file from windows explorer. I have checked and could confirm that it worked as expected, ie. I could see the log on windows everytime.

Please let us know how you go.

Thanks and regards,
Bruce
Message was edited by: bruceduong

Hi Delores,

We would like to ask if you have a chance to check out the preference to force the logon window displayed everytime.

Please let us know if anything else we could help.

Thanks,
Bruce

Can anyone please confirm this “error” in version 6.3?

bruceduong: So you say it should be fixed in 6.5?

Hi Timm,

I confirm that this issue is in 6.3 and we have fixed it in 6.5 (CR 9004).

Thanks,
Vincent

Great. I appreciate your quick reply.