Toad World® Forums

pop up pops under

Sometimes the pop-up “Execution has terminated.” for the debugger pops under the
main window. When it does this, there is no way to click on it, nor is there a
way to move the main window aside so that the pop-up is exposed.

This is not the only pop-up that does this. I suspect it has something to do
with the fact that I use two monitors.

The only way I can bring the pop-up to the top is to go to the task manager and
choose the “Switch To” button.

Is there a fix or workaround for this?

Mike

2 suggestions

  1. You can turn off that “Execution has terminated” message in debugger options.

  2. When this happens, open the task manager and select the toad application.
    This sometimes will bring a stuck window to the front.
    image001.jpeg

I think I know the problem.

When I choose Halt for debugger (the little hand icon), first the “Execution has
Terminated” box pops up on top of the main toad window. Then, in the blink of an
eye, the “Output” box pops up. This causes the main toad window to also come to
the top which instantly covers the “Execution has Terminated” box.

I don’t know why this “Output” box started popping up. It has two
tabs, a “General” tab and a “COM_APP@DMS1_DEV”. I
can’t figure out how to make the “Output” box stop popping up.

Thanks,

Mike

On Thu, Oct 6, 2011 at 11:44 AM, Brad Boddicker
wrote:

2 suggestions

 

1. You can turn off that "Execution has terminated" message in debugger
options.

2. When this happens, open the task manager and select the toad application.
 This sometimes will bring a stuck window to the front.

Which version of Toad are you on?
image001.jpeg

Forget my last question. It appears that your output panel is floating. Look at
Toad’s main toolbar, do you see “default” in the dropdown? Next to the dropdown,
there should be a button dropdown, select that and choose “Restore default
desktop”

From now on, your output window should open docked to the bottom of Toad
image001.jpeg

Thanks Brad,

Yeah my Output was a floater. In theory, that should be perfectly okay, i.e. not
cause a modal dialog box to be covered by it’s parent.

Anyway, docked it and now it’s fine.

Thanks,

Mike

On Thu, Oct 6, 2011 at 12:35 PM, Brad Boddicker
wrote:

Forget my last question.  It appears that your output panel is floating. 
Look at Toad's main toolbar, do you see "default" in the
dropdown?  Next to the dropdown, there should be a button dropdown, select
that and choose "Restore default desktop"

 

From now on, your output window should open docked to the bottom of Toad

Reminds me of a classic movie quote. Floaters cause more harm than good, that’s
why we now prevent them in the Editor. Maybe we should prevent them in the
entire pool.
image001.jpeg