Toad World® Forums

Problems with Feature Export to Graphic File


#1

Hello,

I have a problem with Export to graphic file. It doesn´t generate a jpg nor a bmp file.

Out of Memory??? How much do we need?

EurekaLog 6.0.14

Application:

1.1 Start Date : Wed, 3 Sep 2008 14:22:29 +0200
1.2 Name/Description: TDM.exe - (ERD Designer)
1.3 Version Number : 3.2.4.3
1.4 Parameters :
1.5 Compilation Date: Thu, 3 Jul 2008 11:32:38 +0200
1.6 Up Time : 9 minutes, 35 seconds

Exception:

2.1 Date : Wed, 3 Sep 2008 14:32:05 +0200
2.2 Address : 0042D192
2.3 Module Name : TDM.exe - (ERD Designer)
2.4 Module Version: 3.2.4.3
2.5 Type : EStreamError
2.6 Message : Out of memory while expanding memory stream.
2.7 ID : FAE1
2.8 Count : 1
2.9 Status : New
2.10 Note :

User:

3.1 ID : xxx
3.2 Name : xxx
3.3 Email : xxx
3.4 Company : xxx
3.5 Privileges: SeChangeNotifyPrivilege - ON
SeSecurityPrivilege - OFF
SeBackupPrivilege - OFF
SeRestorePrivilege - OFF
SeSystemtimePrivilege - OFF
SeShutdownPrivilege - OFF
SeRemoteShutdownPrivilege - OFF
SeTakeOwnershipPrivilege - OFF
SeDebugPrivilege - OFF
SeSystemEnvironmentPrivilege - OFF
SeSystemProfilePrivilege - OFF
SeProfileSingleProcessPrivilege - OFF
SeIncreaseBasePriorityPrivilege - OFF
SeLoadDriverPrivilege - ON
SeCreatePagefilePrivilege - OFF
SeIncreaseQuotaPrivilege - OFF
SeUndockPrivilege - ON
SeManageVolumePrivilege - OFF
SeImpersonatePrivilege - ON
SeCreateGlobalPrivilege - ON

Active Controls:

4.1 Form Class : Tf_Main.UnicodeClass
4.2 Form Text : Toad Data Modeler
4.3 Control Class: TPERDesigner2.UnicodeClass
4.4 Control Text :

Computer:

5.1 Name :
5.2 Total Memory : 3071 Mb
5.3 Free Memory : 1752 Mb
5.4 Total Disk : 30,01 Gb
5.5 Free Disk : 14,69 Gb
5.6 System Up Time: 4 hours, 18 minutes, 37 seconds
5.7 Processor : Intel® Core™2 Duo CPU T7500 @ 2.20GHz
5.8 Display Mode : 1680 x 1050, 32 bit
5.9 Display DPI : 120
5.10 Video Card : ATI Mobility Radeon HD 2600 (driver 8.391.2.1110 - RAM 256 MB)
5.11 Printer : Xerox DWC Pro 610 (driver 6.0.6000.16386)

Operating System:

6.1 Type : Microsoft Windows XP
6.2 Build # : 2600
6.3 Update : Service Pack 2
6.4 Language: German
6.5 Charset : 0

Network:

7.1 IP Address: xxx - 000.000.000.000
7.2 Submask : xxx - 000.000.000.000
7.3 Gateway : xxx - 000.000.000.000
7.4 DNS 1 : xxx - 000.000.000.000
7.5 DNS 2 : xxx - 000.000.000.000


#2

Hello Gerald,

Sorry to hear about the trouble.
We need to have the whole eurekalog, particularly the tab Call Stack.

Anyway, please take notice of the Copy to Clipboard checkbox on the Error dialog. Select this checkbox and confirm OK. Then paste the text here or to a doc and send it to us (you can send it to modeling@quest.com).

We need to have a look at it. Thanks in advance.

Note: Flash movie on EurekaLog:
http://modeling.inside.quest.com/entry.jspa?externalID=2061&categoryID=158

Regards,

Vladka + TDM Team


#3

Also, please write us how many entities and relationships you have in your model. (See e.g. Model menu | Information about Model).

Thanks!

Regards,

Vladka


#4

OK thx, for the fast reply

Here the first information:

Data Types: 50

Entities: 172
Relationships: 141

Attributes: 4283
Keys: 172
Indexes: 182

Rest: 0


#5

Hi,

how big is your model in MB?Can you try uncheck option Color and do export?

Tomas
QA


#6

I think I got a wrong email adress to reply to??

The following message to communities2@questmail.info was undeliverable.
The reason for the problem:
5.1.0 - Unknown address error 553-‘sorry, mail to that recipient is not accepted (#5.7.1)’


#7

the size is only 7.5 MB

thx

Gerald


#8

PS: To Uncheck the colour option caused the same problem

(except I had to restart the TDM if I did the export 2 times in a row) :slight_smile:


#9

Hello Gerald,

Just to let you know that we received both EurekaLog files from you (sent to modeling@quest.com). I’ve forwarded them to our developers. As soon as I know more, I’ll write.

Thanks.

Regards,

Vladka


#10

Hello Gerald,

We have managed to simulate the problem but with the following error message:
Not enough storage is available to process this command.

A new CR has been created - # 53 617.
We will need some time to verify the problem. Thanks very much for your patience.

Regards,

Vladka


#11

Hi vladka I am happy to hear your problem is solved.