Toad World® Forums

QSR.exe Access is Denied

Just installed latest version 13.1.1.5 with DBA Module on Windows 10 (latest patches) and getting "Access is denied" error when trying to run Editor >> Execute SQL Via TSR.

Capture

Any thoughts?

Thanks,

Jeff

Hi Jeff,

I'm not able to reproduce this error in Toad 13.1.1.5 in either a Windows 7 or Windows 10 environment (with all latest patches). Would you be able to zip up your Application Data folder (in Options -> General -> Application Data Directory) and send them to me in a private message on here (click on my profile, then click the "Message" button)? I can then try to reproduce the issue using your user files to see if it's caused by something inside that. If not, it may be something inside your copy of Windows 10 that's causing the issue.

Can you run the same script by pressing F5 in the editor? Do you receive an error there as well?

Thanks,

-John

Hi John,

Thanks for the quick reply. I have zipped up the folder as requested, but cannot find a “message” button when I click your profile. Just wondering if I’m missing
a privilege or setting?

Cheers!

Jeff

Hi Jeff,

I'm not sure. I can see the button on your profile so I assumed you could see it for mine as well. Well, instead go ahead and simply send it to john[dot]bowman@quest[dot]com.

-John

I too have the same exact error with the latest version of TOAD.

image

I only receive it with QSR.exe. SQLPLUS and Toad work fine.

Mike

I will add that I dont have the error when running 13.1.0.78. Issue is only with 13.1.1.5. Running Windows 10 with Cylance for Virus protection.

Mike

I just got a case from Michael and I'll report back with my findings.

Thank you Milton!

Here if you need anything from me.

Thanks,

Jeff

Hi, I reset customer 13.1 folder and still the same issue in customer PC. I took the entire 13.1 folder and replaces it in my PC and restart Toad. I run a couple of queries (Editor >> Execute SQL Via TSR and is working as expected. I guess the error will show with any basic query.

I am checking customer logs more carefully and see what I can find there.

QUERY

Thank you!

Jeff

I had the same problem.
I ran qsr from toad started as admin once and now it's working.
Problem may be that script files are written to and execuded from %UserProfile%\AppData\Local\Temp
and not from somewhere in
%UserProfile%\AppData\Roaming\Quest Software\Toad for Oracle\13.1

I just tried to start Toad as admin, which we have the ability to do, but Toad requested a new license as the initial install and license config was done as my
non-admin account. I’m going to try and enter the same license codes and see if that works. Will update at that point. Thank you!

You should not use a different account. In that case a different directory will be used for executing the scripts.
Try to get admin rights assigned (temporarily?) for your actual account. Then right-click > Run as admin