Toad World® Forums

Question from CS2 user

Hi,

After using CS2 for a long time I've finally decided to look at its replacement. The interface is a little different, but similar enough that I'm managing to find my way around.

I have a couple of early questions.

There is something weird with screen painting. It seems to flash a lot. I am using the tool in a virtual machine, but I have been using CS2 the same way and it doesn't have the same 'problem'.

It seems slow. Much much slower than CS2 (in the same environment). Is this my imagination or has the additional functionality caused the slowdown?

I'm seeing font-related (?) issues when displaying certain dialogs (see attached image). It doesn't seem to matter what font I choose (in this case it is Arial, 8), some stuff gets hidden.

I'm sure I'll have more questions, but that's it for now.

Thanks,

Steve

Hi Steve,

Thanks for your questions. Let me reply.

>The interface is a little different, but similar enough that I’m managing to find my way around.
Yes, TDM 3 is a new tool written from scratch. If you start exploring TDM, please feel free to watch any of our instructional flash movies available at:
http://modeling.inside.quest.com/kbcategory.jspa?categoryID=158

Please see the [Getting started] movies and others.

Of course, ask any questions. Our team is fully at your disposal.

>There is something weird with screen painting. It seems to flash a lot. I am using the tool in a virtual machine, but I have been using CS2 the same way and it doesn’t have the same ‘problem’.
Unfortunately, I’m not sure what exactly you mean. Nevertheless, when I’m changing e.g. size of a form or dialog, there is a kind of flash as the items in the form (content of the form) are being resized. Or when you select particular item in object properties dialog, the dialog refreshes according to it (e.g. when you select particular data type, some boxes hide, some show etc.)
Possibly, it might happen as you run it on a virtual machine… It’s hard to say.
Anyway, if you can, please try to describe the problem in detail. Thanks.

>It seems slow. Much much slower than CS2 (in the same environment). Is this my imagination or has the additional functionality caused the slowdown?
Yes, TDM is slower than CS2 as it has many functionalities that are missing in CS2 (alter scripts, model update, modeless dialogs and many more). TDM files are in XML format (CS2 files were in binary format). TDM uses packages for every supported database. - If you like to speed up TDM, install support of only those databases that you will work with.
Please see some tips in our Library, e.g. at:
http://modeling.inside.quest.com/entry.jspa?externalID=1981&categoryID=159

>I’m seeing font-related (?) issues when displaying certain dialogs (see attached image). It doesn’t seem to matter what font I choose (in this case it is Arial, 8), some stuff gets hidden.
Similar problems occurred in old TDM versions. What TDM version do you use? Also, what is your screen resolution? Do you work on Vista?
Please try to change size of the dialog. Does anything change?
Thanks for the details.

I look forward to hearing from you.

Regards,

Vladka + TDM Team (old CS2 tem)

Thanks for the reply Vladka. For some reason I now cannot reproduce the ‘Font related’ problem.

With the screen painting issue it is as if the entire screen is being erased and then redrawn - giving a sort of blinking or flashing effect. For example, if I open the sample (Videorental) model (which takes around 7 seconds), I get the ‘All Items’ tab displayed. If I then select ‘Open All Designers’, it takes another 37 seconds, and seems to redraw the screen dozens of times. Even the menu bar - which I wouldn’t have thought needs redrawing appears to be cleared and redrawn many times in this simple operation.

I run a bunch of other stuff in my VM (e.g. Toad for Oracle) and have never seen anything like that before.

It’s not a show stopper for me obviously. I just thought it was a bit strange.

Thanks,

Steve

Hi Steve,

It’s strange. Do you have a possibility to check it on another PC (not virtual)?
Also, the time for loading Videorental model and its WS is too long. When I select Open All Designers for the Videorental model, I wait for about three seconds.
When you select this option, the main work area (Application Window) needs to refresh.

Our testers say the flashing is different in different OS. It’s more visible on Vista and less visible e.g. on Windows 2000.

Regards,

Vladka

I realize this is an old post but I am experiencing the ‘flashing’ problem. I am not on a virtual machine. I’m running Toad DM 5.4 on Win 8.1. It was not doing this previously but has been constantly flashing since I started working several hours ago. I’ve exited, restarted and nothing seems to help. It even does this when there is not a model loaded.

Hello there,

When you have no loaded models, which parts of the UI are flashing? Which windows in TDM are open? You could try resetting the application layout by deleting the TDM.txe file in “C:\Users*username*\AppData\Roaming\Dell\Toad Data Modeler\Installation #\Configs\TDM”. But before you do that, please send us the contents of the entire Configs folder for analysis, the problem might be caused by specific settings.

Also, recording the flashing effect would help us greatly. If you’d prefer, you can send the files to my e-mail (lukas.knapek@quest.com)

Regards,

Lukas