Toad World® Forums

Scheduled Task fails - WnfStateChangeTrigger error

Hello,
My automated tasks fails showing the following error - (1,1148):WnfStateChangeTrigger
I have already checked the box for 'Use Task Scheduler 1.0'.
My TDP version is 4.3.0.718 (32 bit) on Windows 10.
Please let me know how this can be resolved.
Thanks,
Dmitry

Hi Dmitry,
can you try it with TDP 5.0?

Hi, Dan!

I have not been able to upgrade to 5.0. A few month ago, when tried updating, it was saying that Microsoft NET was not up-to-date, and I was unable to install/upgrade it. This time, when I tried, the TDP installation exe file crashed.

Also, correction on the original issue:

  • I was getting two errors "WnfStateChangeTrigger" and "EndBoundary" when I tried running a scheduled task by clicking Start Task in Job Manager. Made an assumption that the error will persist when the task at the scheduled time.
  • The job ran fine by itself so I suppose the error was just when I was force started it for testing purposes.

What's your curent .NET version and which version of Win 10 is it?

Windows 10. Version 1703. OS Build 15063.1928.
Microsoft.NET Framework - 4.0.0.0

image

Ok, that's unfortunately too general an error to troubleshoot.
Can you try upgrading .NET to the newest version, remove your Toad user data and then try reinstalling? If 5.0.6 is not working maybe 5.0.4 will work for you.

Dan,

Thanks a lot for your suggestions! I have tried installing 5.0.6 after upgrading to the newest .NET and still got the same error.
Then i realized that I did not remove my user data. With that a couple of questions:

  • How do I remove the user data?
  • Will this include removing all of my connections, custom settings, snippets, and interface changes? If so, how do I back them up and apply after installing a new product? By backing up from C:\Documents and Settings%USER%\Application Data\Quest Software\Toad for Oracle\User Files?

Thanks a lot!
Dmitry

Hi Dmitry,
we keep user data here - C:\Users\ %username% \AppData\Roaming\Quest Software\Toad Data Point 5.0
Backup the whole folder and see if it changes anything.
Are you installing with admin rights?