Toad World® Forums

Schema Browser ALT+F3


#1

Since earlier version of Toad I use ALT+F3 in the Schema Browser to generate a script with the table selected. In the new version 10.6 sometimes it works, sometimes it doesn’t.

Why?

I very confused.

Thanx.


#2

It could be that ALT is activating the main menu, and the keystroke isn’t
making it to the list of objects in the schema browser.

I just took a look at the source code – you don’t need to use the
Alt key, just F3 for a select statement without ROWID or CTRL+F3 for a select
statement with ROWID.


#3

F3 and CTRL+F3 works but if I use a table from my schema the script doesn’t have the “tables alias” but if I for example I try F3 with a view from the sys user TOAD put a letter as a “alias”

why this happen?
Imagen1.jpeg


#4

F3 and CTRL+F3 works but if I use a table from my schema the script doesn’t have the “tables alias” but if I for example I try F3 with a view from the sys user TOAD put a letter as a “alias”

why this happen?
Imagen2.jpeg


#5

You just found a bug! I will fix it.

To make it not use any alias, go to Options -> Schema Browser -> Data Tab.

Uncheck “Use alias for table name in query”.


#6

After Uncheck the option F3 is always working but it’s very useful to have the alias in the tables. I hope next version will fix this little bug.

Thanx!


#7

OK, This will be fixed in the next beta.