Toad World® Forums

session is blocked while background job runs

All,

First of all: best wishes for the new year to everyone!

I'm currently on 12.9.0.12.
In the Schema Browser, I started a scheduled batch job (i,e. right-clicked the job, then selected Execute).
This earned me two problems:

  1. Rather than execute the job in the background, the job is being executed 'interactively', i.e. my session is blocked while the job runs :frowning:

  2. A white bar is created over the window, which remains in place, irrespective of what I do. I can minimize the Toad window to the task bar, put another application on the screen, but whatever I do. part of the screen remains blocked by a white bar. When I move the mouse over it, it will change shape to a running circle, indicating it is waiting for something to happen.

I've put a second Toad on the screen, producting the attached screenshot:

Remember: the white bar is from the first Toad session, which is blocked by the execution of a job, the Toad window you see is my second Toad instance.
Working with part of the screen blocked by an unmovable large white bar is less than ideal, to say the least.

Would you please fix issue nr.2? A fix for issue nr 1 would be nice too, but is (at least for me) less urgent.

Kind regards,
Abe Kornelis

To make it run in the background, choose “Do not use current session” in the dialog that appears when you rt-click the job and choose “Run”. I’ll take a look at your white bar.

John,

thanks for the suggestion. Are we talking the same software?

When I right-clikc the job in the schema-browser, I get a list of options.
No option is present that comes even close to “Do not use current session”.
No option “Run” is available either.

Option “Execute” is available, but will just execute, without providing any pop-up whatsoever.

I tried creating a screenshot of the pop-up, but the pop-up disappears as soon as I start the clip program :frowning:

Kind regards,
Abe

Oh sorry, you are talking about dbms_jobs. I was talking about scheduler jobs. As far as I can tell, Oracle doesn’t provide a way to run the dbms_jobs in the background.

John,

Yes, indeed. I’m sorry I did not make that explicit.
I never thought of scheduler_jobs as we do all of our scheduling with dbms_jobs and/or Unix crontab.

Next time around, I’ll juist change the scheduled time to “ten seconds from now”.

Kind regards,
Abe

Scheduler jobs are so much nicer. Give them a try.

John,

Figuring out the differences has been on my wish list ever since I discovered they exist. In practice, I wouldn’t know how to find time for such an exercise. Leave alone convince my colleagues (and management) that it is worth the effort to convert.

From what I’ve seen I think it comes much closer to a proper Job Management system.

Let’s dread the day there’;s nothing left to desire for improvement :wink:

Abe

===

If/when you switch to them, you’ll say “wow, we should have done this a long time ago!”