Toad World® Forums

Toad 10.6.1.3 locks up when I try click the filter button

The filter worked fine up until about 10 days ago. In thinking back I killed a session where a filter hung for over an hour. I don’t remember if I was able to use the filter function after that or not. I don’t use Toad every day or even every other day so can’t be sure if it worked after I killed that session. I believe I used task manager to kill the session. I’m about ready to uninstall and reinstall unless someone has a better idea. Thanks. Andy

Can you be more specific about which filter button? There are a few of them in
Toad.

The filter I’m haveing the issue with is used with tables and views. One my setup which I haven’t customized so I assume it’s pretty standard it sits on the left of the row of icons just above the data and below the various option tabs for the tables/views i.e. columns, indexes, constraints, triggers, data, etc.

Thanks,

Andy

Hmm, I’m not sure what could be the problem, but I have some thoughts.

When you click that button, the first thing we do is create parse the filter XML
file. The file is User Files\
schema>_TableFilters.XML. This file shouldn’t be very big and should
parse very fast. We did have problems in the past with special characters in the
schema name causing problems here, but I think that’s all fixed for 10.6.

We may issue a couple of queries to load column and partition information. If
your columns tab and partitions tab both load quickly, then there should be no
problems here.

Next, we create the form. This goes fast too and I can’t imagine
that’s the problem.

I just had a thought – are you sure it’s locked up and the dialog
isn’t just off screen? Does your CPU usage go up or does Toad just freeze
w/o CPU time? If no CPU time, try hitting ESC and see if you get control back.
If you do, close Toad, edit Toad.ini (also in user files folder), look for these
lines:

FilterSortW=633

FilterSortH=386

FilterSortT=404

FilterSortL=810

(the numbers will be different)

And delete them. Save and close Toad.ini, try Toad again.

-John

John,

That did it. Thanks for your help much better than reinstalling. Can you tell my what caused the problem in the first place?

Andy

The window remembers its size and position. It sounds like it was just coming up
off screen. So maybe you had 2 monitors or a large monitor one time you ran Toad
and opened that window…then you moved it to a position that didn’t
exist on your new monitor. I’ll try to repeat that scenario today and
prevent it from being a problem in the next release.

John,

I replied to *justoracledba about the problem with main screen not coming up. I looked at the Toad.ini file and found the [MainForm] area which changed when I moved the area around. I think the TOP number was negative and that changing it to a positive # would fix the problem.

Andy*

Thanks for this fix, it solved one of my problems too
I also have a problem with the logon window - where I connect to a database. Do you know which values should I change to get that to display again?

Sorry for the delay. Look for [LOGIN] in Toad.ini for the login window
positions.

I am using the latest version of Toad for Oracle (11.x) and I started experiencing this same issue on Friday. I’ve searched my harddrive for the TOAD.ini file without any luck. I’ve installed the application to the default location, can you provide the actual path to this file so that I may try the fix you have posted?

Thank you,

Danielle

C:\Documents and Settings%WINDOWS-USERNAME%\AppData\Roaming\Quest Software\Toad
for Oracle\11.0\User Files

C:\Users%WINDOWS-USERNAME%\AppData\Roaming\Quest Software\Toad for
Oracle\11.0\User Files

The easiest way to locate your toad.ini file (and all other user files) is
View>Options>General. Under the “Application data directory” press “Open
Folder.”
~WRD000.jpeg

The easiest way to locate your toad.ini file (and all other user files) is
View>Options>General. Under the “Application data directory” press “Open
Folder.”
image001.jpeg

The easiest way to locate your toad.ini file (and all other user files) is
View>Options>General. Under the “Application data directory” press “Open
Folder.”
image001.jpeg

For me, it’s

C:\Users\jdorlon\AppData\Roaming\Quest Software\Toad for Oracle\11.0\User
Files\Toad.ini

On Windows XP, it would be

C:\Documents and Settings\John Dorlon\Application Data\Quest Software\Toad for
Oracle\11.0\User Files\Toad.ini

Thanks! Deleting the four lines from the toad.ini file fixed the problem for me.

Thanks! Deleting the four lines from the toad.ini file fixed the problem for me too !

I have the same “lock up” issue with 10.6.0.42 but I don’t have the Toad.ini file anywhere in the in C:\Program Files\Quest Software directory where it was installed.

Is there another solution for this version?

Thank You,

theKGB

You are looking in the wrong folder. It’s slightly different for everyone, but this should give you a clue…mine is in:

C:\Users\jdorlon\AppData\Roaming\Quest Software\Toad for Oracle\10.6

Resolved, thank you John!

The folder ‘AppData’ was hidden and after unhiding it I was able to get to the Toad.ini file and remove the 4 lines.