Toad World® Forums

Single Record View - field background color


#1

Hi,

Running Toad version 10.1.1.8 on Windows 7 using an Aero theme - when I open window “Single Record View” the background color of the data fields are dark grey!

The text being black it is almost impossible to read the content…:frowning:

In Toad I have tried to change text- and background color of both editor and data grid and also “Visual Style” without any luck - anyone who knows how to fix this problem?

BR Martin Z.

PS: If I (in Windows) change my desktop theme from “Aero” to “Windows Classic”, then I can read the text (black on light grey) but my desktop looks like “Windows 95 retro” - not very cool…


#2

It always strikes me as odd how these things come up back to back. I’m not sure if it wouldn’t strike me as odd if they didn’t come up at all, or came up front to front.

Anyway, this just came up over on the Beta board where things are getting very Friday.

When the grid is read-only the controls on the Single Record Viewer use the color of buttons. When read-write, they should be white. So I think the only way to control that is to modify your Windows Theme.

For 10.5 we now have a whole new Styles feature for Grids where you can control everything. And it’s now on the list to be able to apply Styles to the Single Record Viewer. So that should make it in also.


#3

Desktop -> Rt-Click -> Properties -> Appearance -> Advanced ->
Change “Item” to “3D Objects” -> The color setting
here is the read-only color.

If you include ROWID in your select statement, the fields will be read-write and
white.


#4

Complimentary answers we offered


#5

Yes. One with the users, our minds are.


#6

I have already tried changing the colors of the “3D Objects”, it doesn’t have any effect on either field text or field background - it only changes the background color of the window.

Including the ROWID is an ok workaround, but cannot be included in a view without a preserved table…:frowning:

Looking forward to 10.5…:-))

BR Martin Z.


#7

“3D objects” is the setting that changes it in XP. If you have Vista
or 7, I’m not sure…but it should be one of those system colors.


#8

I’m on Windows 7 and I have tried to change all color settings without any luck - the only thing that works for me is reverting back to “Windows Classic”, and that’s not really an option…

BR Martin Z.